Window managers stop responding

Short post because I have tried to post this several times.

My window mangers seem to stop working after an unspecified amount of time. Could be a few minutes or a few hours.
Current focused window continues to receive keyboard input but I cannot switch/kill/spawn other windows. Even if I kill the process of other windows using a tty or even a term if I’m lucky and that is what is focused, they continue to be rendered.

I have tried several window managers including awesomeWM, DWM, i3, bspwm to name a few and they all share the same issue. Seem to have a bit better luck using full desktop environments like KDE plasma.
Happens on several of my machines (which all share the same configs) all running latest Manjaro KDE.
(Both my Lenovo X220, and Desktop Ryzen 5 2600, Saphire 390 GPU)
Killing Xorg and restarting x11 fixes the issue but that is essentially like a reboot in terms of workflow interruption.
I have since set up a binding in Xorg itself to kill the Xserver which triggers fine.
Been happening for a few weeks and none of the updates in that time seem to have made it better or worse.

Living in a tty to avoid it is getting a little frustrating so any ideas for how to debug this further would be greatly appreciated.


Working solely on the window managers openbox and compiz - no problems - it is a configuration problem on your side.

I have no idea what you can do to troubleshoot - but I am fairly certain - you are carrying a config issue from system to system.

I could be a software you install in every configuration or it could be a theme.

I agree it’s likely a configuration issue. Here is a full list of all the software I often install on my machines.

keychain fd ripgrep fzf bat tmux neovim flameshot synergy steam code youtube-dl mpv youtube-viewer zathura yay vim nodejs yarn ttf-jetbrains-mono alacritty emacs python-neovim unzip xsel

Only thing which stands out to me is synergy, though it seems to happen even if that isn’t running.

Been digging though all my configs for the last few weeks looking for the issue but I’ve come up empty handed. 7+ years of tailoring configs gives me a lot to look through… Also means that ditching the configs and starting from scratch is far from ideal.

The other thing I suspect may be causing the problem is KDE itself. I had never used KDE before installing Manjaro and the issue seems to have appeared when I tried to change back to using a window manager instead of a full desktop enviroment. Often when I run into this issue and open htop in a tty there is a kwin process using 100% cpu even if I’m not using KDE as my desktop environment. Killing it seems to have no effect and I am still forced to kill Xorg to get a working graphical environment again.

At this point I’m running out of ideas on how I can track down the cause of the issue.

sudo pacman -Rns kwin

Check the list of dependencies removed - if you spot somthing you need - abort - then rerun using only

sudo pacman -R kwin