Window managers require Fn key with F1-F12

I recently added an extension to my XMonad config to allow me to raise, lower and toggle mute volume like on Plasma.

However, in Plasma, I just press F2 or similar keys and it works, and in XMonad, I have to do Fn+F2

I can also see this behaviour in other places, like FX keys in vim, needing to press Ctrl+Alt+Fn+Fx instead of Ctrl+Alt+Fx.

Is there any way to override this behaviour if this is software-specific?

In most cases this is hardware defined. If your function keys has the F-label in blue the hardware is reversed of what you normally expect.

Some laptop vendors provide a firmware setting to reverse it.

Oh wait, just realised that this is indeed hardware specific. My laptop has a small FnLock key that overrides that behaviour. Thanks a lot!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.