Window Manager (or Xorg?) broken after upgrade

Greetings.
I'm using Manjaro 32bit Xfce4. After my last pacman -Syu(it was a big upgrade), I am stuck with what appears to be a broken window manager. All windows are borderless and I cannot switch focus anymore. It's always the topmost window that has focus and I need to close it in order to reach the underlying windows. The symptoms are exactly as described in this post, but I don't use KDE and only have one active DM (LightDM), so I'm not really sure how to fix this.

Just before the upgrade, I ran into the problem described here and had to manually execute

sudo pacman -Rdd libxpresent libxxf86dga libxxf86misc && sudo pacman -Syu

So maybe it's not the WMs fault but something went wrong with Xorg? Note that in my case, pacman didn't complain about inputproto and dmxproto, but libxpresent, so I simply changed it. Maybe that was a mistake?

To further complicate the matter, ever since I first installed the system, I get this error message with every pacman -Syu:

error: failed to commit transaction (conflicting files)
/etc/skel/.config/autostart/ exists in both 'manjaro-hello' and 'manjaro-xfce-minimal-settings'
manjaro-xfce-minimal-settings: /etc/skel/.config/autostart exists in filesystem

At the time, I simply excluded these from updating with --ignore, but I'd appreciate any hints on how to fix this to make sure it's not causing the first problem.

I would be deeply thankful if someone can help me fix this.
See you.
dervonnebenaan

Since I am not allowed to post more that two links at the same time, here's the output of inxi -Fxxxz: https://pastebin.com/Z83pYgNt
And my /var/log/pacman.log of the upgrade that triggered the problem: https://pastebin.com/Urwh1ZAC

I had a similar case with WM.
The problem turned out to be the libxpresent package - version 1.0.0+2+gdd6771c-1, required by xfwm4.
This version of libxpresent had a presentproto dependency which is no longer present in Manjaro32, hence WM stopped working.

The solution I used was:

  • download from the Manjaro32-testing repository the libxpresent package (version 1.0.0-2.0), (in which there in no presentproto dependency ), and its installation (locally using Pamac);
  • adding the libxpresent package to the ignore list in Pamac (so that the system does not request to upgrade to the version with the wrong dependency).
3 Likes

This worked like a charm. You're my hero! ^^

As for the problem mentioned last in my post, I simply uninstalled manjaro-hello as I don't really need a fresh-install-greeter.

1 Like

@dervonnebenaan, please do all others a favor and mark the post helping you to solve your issue as Solution. Thanks!

Excellent! Thank you so much!

I'm new, I still don't understand much, what are the commands to update? I downloaded that, but I don't know what to do

Help me, please. :pleading_face:¿How to install the package?

/home/belen/Download/libxpresent-1.0.0-2.0-i686.pkg.tar.xz: invalid or corrupted package (PGP signature)

@bergkatse
You write about two problems:

  1. How to install a package locally.
    1a. download it from any Manjaro Repository
    1b. install it locally:
  • via console:
    pamac install /home/belen/Download/libxpresent-1.0.0-2.0-i686.pkg.tar.xz
  • or via Pamac's Icon > Install Local Packages (and choose your package).
  1. " invalid or corrupted package" (but probably this is not a problem in your case)
    Please check this:
    Issues with "signature is marginal trust" or "invalid or corrupted package"
    Invalid or Corrupted Package (PGP signature) Different error appeared
1 Like

F*ck


I do not know what to do
I already used the commands:

sudo pacman-key --populate
sudo pacman-key --refresh-keys

Yeahhhh baby, YEAHHH. I did it

THANK YOU :relaxed:

Forum kindly sponsored by