Window Cycle slow


#1

Hi,

is anyone else having issues with windows cycling ? When i press Alt+Tab it takes nearly over 1 sec for it to show up/cycle.

is there a way to speed up?

System:
  Host: lino-pc Kernel: 4.20.0-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: XPS 13 9360 v: N/A serial: <filter> 
  Mobo: Dell model: 0TPN17 v: A00 serial: <filter> UEFI: Dell v: 2.10.0 
  date: 09/27/2018 
Battery:
  ID-1: BAT0 charge: 47.1 Wh condition: 60.0/60.0 Wh (100%) 
  model: SMP DELL TP1GT61 status: Discharging 
CPU:
  Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31880 
  Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.3 driver: modesetting unloaded: intel 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) 
  v: 4.5 Mesa 18.3.1 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.20.0-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Bigfoot Networks driver: ath10k_pci v: kernel port: f040 
  bus ID: 3a:00.0 
  IF: wlp58s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-3:2 
Drives:
  Local Storage: total: 238.47 GiB used: 35.54 GiB (14.9%) 
  ID-1: /dev/nvme0n1 vendor: Toshiba model: KXG50ZNV256G NVMe 256GB 
  size: 238.47 GiB 
Partition:
  ID-1: / size: 117.58 GiB used: 35.54 GiB (30.2%) fs: ext4 
  dev: /dev/nvme0n1p8 
  ID-2: swap-1 size: 4.88 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p7 
Sensors:
  System Temperatures: cpu: 37.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 210 Uptime: 4h 09m Memory: 7.52 GiB used: 837.6 MiB (10.9%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.28

#2

This has been mentioned quite a few times in the Forum. An example:

The issue is probably related to the gtk3 version of the window manager xfwm4-gtk3.
Try a different theme and see if it helps.


#3

I was thinking whether there is a way to only change the theme of the task/window switcher to something like adwaita where there is no such delay.


#4

Thanks, works but none of the other themes I like compared to the one am currently using lol hopefully this will get fixed !


#5

As a workaround, you can try this option with your current theme:

This approach has some drawbacks, like switching between top level windows only, but it’s faster compared to the Alt+Tab option. :man_shrugging:


#6

Yh that works alpot faster! Shame it does cycle through them as fast as this.


#7

[I edited out the obnoxious exclamation mark from OP]