Wiki: Please install: Extension: ParserFunctions

Dear Sirs, @philm and collegues,

please install at least the Extension "ParserFunctions" as soon as possible.

What does this do and where will this help us, you may ask:
Please take a look at this information. Extension:ParserFunctions

[ Description ] Enhances parser with logical and string functions
So many templates taken from the Mediawiki site depends on them and won't work without this Extension installed.

Or is this blocked, at least for now, because they may require MediaWiki Version 1.25+?
And you have still installed only 1.22.5?
Since you have after 5 years of using it still no time to upgrade it to a supported state?
I would regret this very much.

So I like to get a suggestion for a solution.
Should we downgrade the templates to a state which can run on the Verson 1.22.5?

It’d be wise for them to upgrade the wiki software ASAP, 1.31.5 is LTS. A quick google search reveals multiple vulnerabilities in MediaWiki 1.22.5. I’m surprised the wiki hasn’t been hacked already.

The last thing Manjaro needs is more reports about poor security efforts on top the others from a couple years ago.

5 Likes

Forum kindly sponsored by