[wiki]Installing VMware



Successful installation

As of version 12.5.6 vmware is again broken.
It is an ever returning issue - an endless fight against the inevitable - and I have thrown the towel in the ring.

This wiki applies to

  • VMware Workstation Pro 12.5.x (commercial evaluation)
  • VMware Workstation Player Pro 12.5.x (free for non-commercial use)


VMware relies on the init.d folder which is not a part of Manjaros requirements so before you start your vmware installer create the folder

sudo mkdir /etc/init.d

Kernel headers

Ensure you have headers installed for your kernel e.g. kernel49

sudo pacman -S linux49-headers

VMware installer

Download the latest installer from vmware.com - substitute the filename with the actual bundled installer

chmod +x VMware-Player-VERSION-ID.ARCH.bundle
sudo ./VMware-Player-VERSION-ID.ARCH.bundle


For vmware product to launch it is required to load vmware daemon. This is done by executing

sudo /etc/init.d/vmware

This can automated by installing the vmware-systemd-services package from AUR

yaourt -S vmware-systemd-services

When installed start the service and enable it to run at boot time

sudo systemctl start vmware
sudo systemctl enable vmware

Kernel modules

VMware needs modules compiled with your kernel headers. Normally this compilation is handled automatically when lauching the main vmplayer / vmware wrapper but in rare cases it has to be done manually.

sudo vmware-modconfig --console --install-all

Every time your kernel is updated you need the kernel headers for the new kernel. Manjaro normally takes care of that part.


Be aware that updating your kernel might break your VMware installation. Compatibility issues has been seen with several kernel updates.

Launch from terminal

VMware Workstation

vmware &

VMware Workstation Player

vmplayer &


Continued from VMWare Will not start

Symptoms versions 12.5.3 - 12.5.4 - 12.5.5

Vmware refuses to launch and services are not working
Starting VMware services:
Virtual machine monitor --------------------------------- failed
Virtual machine communication interface ------------ done
VM communication interface socket family ---------- done
Blocking file system --------------------------------------- done
Virtual ethernet --------------------------------------------- failed
VMware Authentication Daemon ------------------------ done
Vmware refuses to launch even all services running
# /etc/init.d/vmware stop
Stopping VMware services:
   VMware Authentication Daemon                                        done
   VM communication interface socket family                            done
   Virtual machine communication interface                             done
   Virtual machine monitor                                             done
   Blocking file system                                                done
# /etc/init.d/vmware start
Starting VMware services:
   Virtual machine monitor                                             done
   Virtual machine communication interface                             done
   VM communication interface socket family                            done
   Blocking file system                                                done
   Virtual ethernet                                                    done
   VMware Authentication Daemon                                        done
   Shared Memory Available                                             done

Linker dynamic path

Source VMware Community

The dynamic linker cannot find the right version of libcurl.so.4

export LD_LIBRARY_PATH=/usr/lib/vmware/lib/libcurl.so.4:$LD_LIBRARY_PATH
vmware &

Adding it to your .bashrc or .zshrc script won’t do any good as you can still not launch vmware from its desktop file.

Source Danish Technical University

Further research seems to indicate that a user-wide LD_LIBRARY_PATH should be avoided as it can pollute your environment. It seems vmware have ‘forgot’ the path to the linked library libcurl.so.4

The better approach is to edit the vmware / vmplayer wrappers and add the export in it. This approach will expose only to the wrapper the LD_LIBRARY_PATH

Edit vmware wrappers

$ sudo nano /usr/bin/vmware
$ sudo nano /usr/bin/vmplayer
edited content
#!/usr/bin/env bash
# Copyright 2005-2008 VMware, Inc.  All rights reserved.
# Wrapper for the real 'vmware' binary. Ensure that the
# binary will find all the shared libraries it needs. If a shared
# library is not available from any of the standard system-wide
# locations, we provide it from the location where the VMware software
# is installed.

set -e

. $ETCDIR/bootstrap

# for for missing library
export LD_LIBRARY_PATH=/usr/lib/vmware/lib/libcurl.so.4:$LD_LIBRARY_PATH                

----------<snipped away

This works as of versions 12.5.3 - 12.5.4 - 12.5.5 and you can launch vmware / vmplayer from console and from desktopfile. Later releases from VMware might have their own solution to this issue.

[solved] VMWare Will not start
Install vmware-workstaton on manjaro 17
[VMware]Cant compile kernel modules
Reinstall manjaro - vmware won't install
VMware kernel headers for 4.9.51-1-MANJARO not found
VMware Player does not start
Can not start vmware
[VMware]Cant compile kernel modules
VMWare Player - Keeping It Running Without Failure?
VMware Player 7 installation
VMware Player 14 install shows "configuring" but nothing happening

This is a great Tutorial.

Here is one issue I see:

Be aware that updating your kernel might break your VMware installation.

I would change that slightly in light of the ease of changing kernels with Manjaro Settings Manager.

Generally, sub-point releases of kernels never cause a problem for VMware. Therefore, routine Manjaro updates are never a problem.
(I can not say this with certainty, because I’ve only been running Vmware on Linux since 2003.)
(Version changes past the second decimal point are harmless: 4.10.xx = OK).

Only when digits immediately behind the first decimal change will you need to recompile Vmware drivers, and this is usually detected automatically by Vmware the first time you launch it with a new kernel.

Secondly: you will need a fairly complete kernel compile system installed in addition to kernel headers. Make, compiler, etc.)

Third: The Open VMware tools, xf86-video-vmware and xf86-input-vmmouse packages in Manjaro repositories are all you need for a Manjaro Guest. There is no point in trying to compile later versions of these because the later versions only provide VmWare features not available on a Linux Host.


Don’t work for me. When I try to start workstation player it stop silently and for that reason I don’t have any idea what I must do to fix it. Any suggestions ?


I have no idea - I have given up on vmware.


Ok If I want to play windows games and I have single gpu can I use alternative to vmware


You could try with virtualbox.


as much as I know virtual box don’t have good gpu driver and don’t support 3d acceleration


There is 3D support with VirtualBox - Given enough RAM (128MB) you can enable 3D drivers when installing the guest utilities.

However - I have had the need for enhanced graphics support so I don’t know how well it works.