Wifi works on live but not after install

It’s on an old Compaq C700 notebook with a Broadcom wireless adapter.

When I run it live from the USB, wifi works perfectly.

I then install Manjaro and no wifi seems to be there.

‘rfkill list’ shows the adapter is both soft and hard unblocked.
‘ip link’ shows loopback and “enp2s” only.

I tried this both with Gnome and Xfce editions.

What should be my next steps?

Is the module correctly loaded?

lspci -nnk | grep -A3 net

Does it use another module/driver after install? Maybe mode probing was wrong after install and you need to blacklist a driver?

Check:

mhwd -l

if there is a driver for your wifi card available. I guess it is a broadcom card.

Here are some more information about broadcom cards:

https://wiki.archlinux.org/index.php/Broadcom_wireless

lspci -nnk | gre -A3 Net shows a Network controller [0208] Broadcom Inc. and subsidiaries BCM4311 802.11/g WLAN [14e4:4311] device. Both in live and installed, the driver being used is b43-pci-bridge.

The difference is that in live, the loaded kernel modules show only ssb. Installed shows ssb and wl.

mhwd -l shows the driver network-broadcom-wl version 2018.10.07 being used. The output has no changes compared to running it live.

I read the link you suggested and I see it recommends a classic driver for my device, but I have to admit that the blacklisting instructions are a bit confusing to me, considering I have no access to internet in said computer (I’m not sure how the preferred driver/module will be installed).

can you paste the full output of the lspci command you used?

Also,

mhwd -lh -d --pci

A simple explanation:

Drivers in linux are Modules. They are builtin or sometimes added and can be loaded. Linux can probing drivers and use a module automatically. You need to blacklist some modules that the probing expect to probe. Or remove a module and load the right one.

Lets say you have these modules:

b43
ssb
wll

manually you can remove a module from the list temporary:

rmmod b43

and manually you can load a module from the list temporary:

modprobe b43

b43 is the reveres-engineered module

To make it easier. If you don’t want, that the b43 module will be used, then blacklist it:

Create a file blacklist.conf in /etc/modprobe.d/ and write “blacklist b43” into the text file :

sudo echo "blacklist b43" >> /etc/modprobe.d/blacklist.conf

and then reboot.

Check again with

lspci -nnk | grep -A3 net

Which module has been loaded.

Sidenote: I guess there is a blacklist when loading modules on the live environment, but not on local installation.

2 Likes

Problem solved. Here’s what I did:

  1. Installed Manjaro Xfce
  2. Booted into it.
  3. Used the Manjaro Settings Manager > Hardware Configuration tool to uninstall the Broadcom free driver.
  4. Downgraded the Kernel to 4.19 (that’s a step I’m not sure to be required, but this is the same kernel I use in my regular box).
  5. Reboot.

First thing after logging in was the system asking me to join a wi-fi.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.