Wifi very slow intel card

I have a USB drive with Manjaro Gnome installed. Its fully updated, When I boot using this USB on my Dell Latityde 7390 the wifi is very slow. It can drop down to just a few Mb/s

Booting on a Manjaro Gnome iso I get full speed 100/10

Looking at inxi -F i get this on my USB install and when booting the iso:
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi

Can I reset wifi drivers and settings somehow?

Hi @niclasc,
I do not know what kernel version are you using, but you could post the output of inxi -Fazy on this post, in order to receieve help from the forum users.
Meanwhile, you could read the following post.

Hope it help, regards.

I’ve tried Kernel 5.10, 5.9, 5.8 and 5.4 all with tha same problem. If I Boot of a Manjaro install iso then wifi works fine

inxi -Fazy                                                                                                                                       
  Kernel: 5.10.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=e553b735-da30-40dc-bb99-31eedc37c950 rw quiet udev.log_priority=3 
  Desktop: GNOME 3.38.1 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.38.2 
  Distro: Manjaro Linux 
  Type: Laptop System: Dell product: Latitude 7390 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0MXW44 v: A03 serial: <filter> UEFI: Dell v: 1.16.0 
  date: 07/13/2020 
  ID-1: BAT0 charge: 50.8 Wh condition: 50.8/60.0 Wh (85%) volts: 8.3/7.6 
  model: Samsung SDI DELL V49407C type: Li-ion serial: <filter> status: Full 
  Info: Quad Core model: Intel Core i7-8650U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: A (10) microcode: D6 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 33615 
  Speed: 800 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 801 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus ID: 1-5:2 chip ID: 0c45:6717 
  Display: wayland server: X.Org 1.20.9 compositor: gnome-shell driver: nvidia 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 4096x1440 s-dpi: 96 s-size: 1084x381mm (42.7x15.0") 
  s-diag: 1149mm (45.2") 
  Monitor-1: XWAYLAND0 res: 2560x1440 hz: 60 dpi: 108 
  size: 600x340mm (23.6x13.4") diag: 690mm (27.2") 
  Monitor-2: XWAYLAND1 res: 1536x864 hz: 60 dpi: 135 
  size: 290x170mm (11.4x6.7") diag: 336mm (13.2") 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.2.3 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.10.0-1-MANJARO 
  Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: kernel 
  port: f040 bus ID: 00:1f.6 chip ID: 8086:15d7 
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: f040 
  bus ID: 02:00.0 chip ID: 8086:24fd 
  IF: wlp2s0 state: down mac: <filter> 
  Local Storage: total: 248.01 GiB used: 70.08 GiB (28.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda type: USB vendor: Samsung model: SSD 850 EVO 250G 
  size: 232.89 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 0X06 scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Corsair model: Voyager size: 15.12 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: 0.00 
  scheme: MBR 
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: f060 bus ID: 00:17.0 chip ID: 8086.282a rev: 21 
  ID-1: / raw size: 232.59 GiB size: 227.94 GiB (98.00%) 
  used: 60.15 GiB (26.4%) fs: ext4 dev: /dev/sda2 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 51.5 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
  Processes: 277 Uptime: 4h 05m Memory: 15.51 GiB used: 2.51 GiB (16.2%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1142 lib: 327 
  Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.1.08

Hi @niclasc,
I understood your comment, I have no experience on booting from an USB.
I can recommend two other post from the forum whether you could find help:
and ‘WIFI doesn't work with new install, driver is iwlwifi

Maybe, there is a persistence problem in your USB.
Please, consider to read the following post: https://forum.manjaro.org/t/problems-with-booting-shutdown-in-a-persistent-manjaro-usb-drive-win-10-situation/38902


Here are 2 speedtests, Both done using the built in browser

This is booting of manjaro-gnome-20.1.2-minimal-201019-linux58.iso:

And this is my install:

Hi @niclasc,
Your wifi driver is supported ´https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi´ here.
The source code is here.

The only advice I can give to you is to install the driver manually.


I found an old SSD with manjaro gnome installed. It had kernel 5.9.1-1. So perhaps a month old install
I did a speedtest and got this:

Then I did an update. 398 packages got updated. After the update I got this:

Hi @niclasc,
I have no answer at all and instead several questions.
Did you reboot the machine?
Which command or package did you use to make the update?
At last, try with the solution on the following post:
Very slow WiFi after recent update [Unstable Branch]


I updated using package manager and I have reboot more times than I can count.
A clean install using a least a month old iso then the wifi i fine. After an update its broken

In the file /var/lib/NetworkManager/NetworkManager-intern.conf it says “CHANGES TO THIS FILE WILL BE OVERWRITTEN” so why edit that file??

Also that fix is for Realtek RTL8821CE. And I have a Inte card with intel driver

Tried the fix in the link but it did not help. Speed/connection so bad that I cant run the speedtest

    Speedtest by Ookla

     Server: Telenor AB - Stockholm (id = 34441)
        ISP: Telenor Sverige AB
    Latency:     7.18 ms   (1.24 ms jitter)
   Download:     1.12 Mbps (data used: 1.6 MB)                               
     Upload: FAILED                                            
[error] Cannot write: Resource temporarily unavailable

Do you get other results when you turn ecn off sudo sysctl net.ipv4.tcp_ecn=0 or full on sudo sysctl net.ipv4.tcp_ecn=1

None of them helps. I’m at around 1/10 of the speed I should be

sudo sysctl net.ipv4.tcp_ecn=0 gives:

Speedtest by Ookla

     Server: Telenor AB - Stockholm (id = 34441)
        ISP: Telenor Sverige AB
    Latency:     5.19 ms   (2.35 ms jitter)
   Download:    12.01 Mbps (data used: 21.6 MB)                               
     Upload:    35.86 Mbps (data used: 56.4 MB)                               
Packet Loss:     0.0%

And sudo sysctl net.ipv4.tcp_ecn=1 gives:

Speedtest by Ookla

     Server: Telenor AB - Stockholm (id = 34441)
        ISP: Telenor Sverige AB
    Latency:     6.04 ms   (1.35 ms jitter)
   Download:    13.67 Mbps (data used: 20.1 MB)                               
     Upload:    22.18 Mbps (data used: 38.1 MB)                               
Packet Loss:     0.0%

And whats the default setting for this?
ecn off or on?

Ecn 2 is default

With iso manjaro-gnome-20.1.2-minimal-201019-linux58.iso wifi runs at full speed
But with newest iso manjaro-gnome-20.2-minimal-201203-linux59.iso wifi is VERY slow. Just a few Mbits

Something has changed from one old iso to the latesgt so that affects the speed of wifi

If you suspect the wifi driver, you could check which versions are installed on both.
If they differ you could try downgrade the driver to see if that helps…
Start by using the latest iso :wink:

Just crosslinking Manjaro 20.2 Nibia got released to have this issue linked in that thread.
You might also post something there mentioning this thread so more will notice it…

How do I check version of wifi driver?

You could use:

  1. networkctl --no-pager status -a and look for the line that says Path: in the wifi interface.
    fe. mine says: Path: pci-0000:05:00.0
    We now have determined that our WiFi adapter is a PCI device at 0000:05:00.0
  2. Next we determine which kernel driver is used for it:
    lspci -ks 0000:05:00.0
    fe. mine says: Kernel driver in use: wl
  3. Next we determine the file used by that driver/module:
    modinfo -F filename wl
    fe. mine says: /lib/modules/5.9.11-3-MANJARO/extramodules/wl.ko.xz
  4. And finally we find which package provides that file:
    pacman -Qo /lib/modules/5.9.11-3-MANJARO/extramodules/wl.ko.xz
    fe. mine shows it is owned by linux59-broadcom-wl
    Thus my Wifi driver is provided by linux59-broadcom-wl with version

On iso manjaro-gnome-20.1.2-minimal-201019-linux58.iso iwlwifi-ko-xz is owned by linux58 5.8.16-2

On iso manjaro-gnome-20.2-minimal-201203-linux59.iso iwlwifi-ko-xz is owned by linux59 5.9.11-3

2.4Ghz or 5Ghz make any difference?

You could try to downgrade the linux-firmware to the one that has no problem.

Also check your dmesg if you have any microcode sw errors