Wifi unstable on Presario CQ58

Well, I installed latest Manjaro xfce on Presario CQ58, and wifi adapter is apparently working well, but sometimes the tray icon signal power go to half and go to near full again. Working with network without problems, but I made a ping for 5 minutes and I saw that some packets losed:

1285 packets transmitted, 1276 received, 0.700389% packet loss

Is not really good, because the laptop is very near to router (2 meters). Here I have some issues. Any idea?

02:00.0 Network controller: Ralink corp. Device 539a
	DeviceName: Ralink RT5390R 802.11b/g/n 1x1 Wi-Fi Adapter
	Subsystem: Hewlett-Packard Company Device 1839
	Kernel driver in use: rt2800pci
	Kernel modules: rt2800pci

Thanks in advance.

Disable IPv6 and mac address randomization, restart your devices and test again

Tested. Nothing changed. The adapter is internal, not usb.

Well…The problem is simpler than I thought. It was a problem of interference in the router signal. I’ve never set this up, but I’ve tweaked a couple of things on the router’s “advanced” tab and it’s fixed. I think it’s the channel, I have changed from 1 to auto, and it has been switched to channel 11.
So nothing, sorry for the question, problem solved.

1 Like

Wait a moment. Ping test don’t lost anything with this set-up, but signal appears at 45-65% on the xfce nm plug-in.
I think that with the router near (2-3 meters) the signal should be near 100%, it should be like this right?
Either way, it has an interference problem, that’s for sure, but I’ve been looking for things from this adapter all morning and it’s very troublesome on Linux, and it doesn’t seem like it has a solution.

Edit: I tried with a D-link usb adapter and does the same. I mark the problem as solved.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.