Wifi stopped working overnight

Hello everyone!

I need help once again. I’m running Manjaro KDE on a laptop with an Intel i5 Comet Lake for over a year now. I never had any issues with Wifi until now.
Worked fine yesterday but today, when I started the laptop, I had no connection. When I click the network icon it just says “No available connections”. All buttons (Wifi on/off and Flight Mode on/off) are gone.

“lspci -k” tells me

Network Controller: Intel Corporation Comet Lake PCH-LP CNVi Wifi
Device name: On Board Ethernet
Subsystem: Intel Corporation Wi-Fi 6 AX201 160MHz
Kernel driver in use: iwlwifi
Kernel Modules: iwlwifi

“ip link” shows just the loopback, nothing else.

I tried “ip link set wlan0 up” but it tells me it cannot find wlan0. Problem is that I don’t know if the interface is called wlan0 or has any other name.

I’m on kernel 5.10 LTS currently but I also tried 5.4, also doesn’t work.
Any ideas anybody? As I said, was working fine yesterday and I didn’t do any updates or change anything on my system.

PS: Sorry for formatting, typing this on my phone because, well, there’s no internet on my computer;-)

PSPS: Wifi itself works fine on both of my phones.

Check journal for errors:

$ journalctl -b -p err

Could be a fluke.
Did you reboot and/or powercycle the laptop since and does wifi still not work?

This means no wireless interface was created.

In addition to @freggel.doe’s post, please provide output of

sudo dmesg | grep firmware
sudo dmesg | grep iwlwifi
rfkill list

Ich hoffe, das ist so ok, mag das nicht alles abtippen xD
edit Damn, why did I write in German? Sorry! Hope pics are ok, don’t wanna type all this on my phone.

Thats quite a lot, but all unrelated to your wifi problem as far as I can tell.
Try scrolling until you see “other errors” unlike ACPI Error or ACPI BIOS Error.

Did you try rebooting/powercycling and does the problem persist?

“rfkill list” doesn’t give any output.

“iwconfig” says “command not found”

That’s all there is, nothing to scroll.

And yeah, tried restarting and powering off/on multiple times.

Something must have changed when it was working before and is not working now.

Nope, nothing. Last system update via pacman was done 2 days before without any issues. Uploaded some videos to YouTube on Tuesday, encoded some videos on Shotcut, powered off the computer when everything was done. Turned it on again yesterday when I came home from work and Wifi was gone. Hope it’s not the Wifi-card itself, the hardware. Laptop is just in use for a little over a year. Will try some live distro from USB this evening and see if Wifi works there or not.

If nothing changed then there would be no reason for it to have stopped working. Something must have changed.

I would recommend booting up a Windows install to see if the WiFi card works there, if it doesn’t then it likely died.

Another reason could be that you have a fresh filesystem error. Maybe you can boot a live ISO and initialize an fsck operation on your unmounted system partitions.

Yeah, strange, isn’t it? But I definitly didn’t do anything besides encoding and uploading videos. So unless Manjaro changes something by itself (and I’m pretty sure it doesn’t) there’s no good explanation for what happened. Believe me, I was confused also.

May I ask where you see this? Only issue I had lately was a failed update via pamac. Couldn’t update via pacman because of some dependences that couldn’t be resolved. The suggestion here on the forums was to update via pamac (which I never used before) and that ended in a lot of errors after about 20 minutes (looked like pamac was trying to compile something but I couldn’t figure out what it was). Will not use pamac ever again after this, lol. But that was at least three weeks ago, so not really recently.

Sudden errors not linked to any update or other system change always could have the reason that one important file got corrupted. So why not checking it, it cost you only some minutes.

? I didn’t say I won’t check it. Just came home from work, currently downloading Mint to see if Wifi works there. Guess I can use Mint also to check the filesystem, correct?

edit Suse Studio Imagewriter is running for almost an hour now and is at 74%…OMG

No Wifi on Mint also. Looks like a hardware failure :frowning_face:
Anyway, thanks for help folks!

PS: Any suggestions for a USB Wifi adapter that works well with Manjaro on 5Ghz?

PSPS: @Wollie: Ran fsck, filesystem is ok :+1:

I would suggest checking this on a Windows install.

Thx, but why Windows? Stopped working overnight without any changes to the system, doesn’t work on Manjaro and Mint. I’m 99% sure it’s a hardware failure. I would try Windows if there’s a good reason but not for a 1% chance. But you must have any suspicion why it doesn’t work on Linux anymore but could work again on Windows. So, what is your suspicion?

In 0.1% of cases I’ve seen firmware bugs that are only rectified on Windows. Extremely rare I might add, but it’s not like it costs a lot to boot up a Windows install real quick.

I personally would, but honestly the chances are pretty small.

Ok, thx, makes more sense now. Maybe I try if I find time. Unfortunately time’s always the problem for me.

edit Why does it sometimes show who I replied to and sometimes not?