Wifi stopped working after installing Windows 10 on separate disk

Wifi has been working just fine, no issues, until I installed Windows 10 on a separate drive (with separate UEFI partitions on the respective drives) to test the official manufacturer drivers for some other hardware. The idea was that I would switch out the drives whenever I needed to test a driver.

Ever since, the wifi device does not show up in the tray applet (Manjaro Plasma) or in nmcli, but does still show up in sudo lspci -v. I have been using a slow USB wifi adapter (wlp11s0f3u2) since then.
nmcli dev show:

GENERAL.DEVICE:                         wlp11s0f3u2
GENERAL.TYPE:                           wifi
GENERAL.HWADDR:                         ~~:~~:~~:~~:~~:~~
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.CONNECTION:                     ~(Network Name)~
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/1
IP4.ADDRESS[1]:                         192.168.0.~~/24
IP4.ROUTE[1]:                           dst =, nh =, mt = 600
IP4.ROUTE[2]:                           dst =, nh =, mt = 600
IP4.DNS[2]:                             ~~~.~~~.~~.~~
IP4.DOMAIN[1]:                          Home
IP6.ADDRESS[1]:                         ~~~~::~~~~:~~~~:~~~~:~~~~/64
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           dst = fe80::/64, nh = ::, mt = 600

GENERAL.DEVICE:                         enp3s0
GENERAL.TYPE:                           ethernet
GENERAL.HWADDR:                         ~~:~~:~~:~~:~~:~~
GENERAL.MTU:                            1500
GENERAL.STATE:                          20 (unavailable)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --

GENERAL.DEVICE:                         enp4s0
GENERAL.TYPE:                           ethernet
GENERAL.HWADDR:                         ~~:~~:~~:~~:~~:~~
GENERAL.MTU:                            1500
GENERAL.STATE:                          20 (unavailable)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --

GENERAL.DEVICE:                         lo
GENERAL.TYPE:                           loopback
GENERAL.HWADDR:                         00:00:00:00:00:00
GENERAL.MTU:                            65536
GENERAL.STATE:                          10 (unmanaged)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
IP4.GATEWAY:                            --
IP6.ADDRESS[1]:                         ::1/128
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           dst = ::1/128, nh = ::, mt = 256

From sudo lspci -v:

05:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)
        Subsystem: Intel Corporation Device 0084
        Flags: fast devsel, IRQ 36, IOMMU group 22
        Memory at fbe00000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [c8] Power Management version 3
        Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [40] Express Endpoint, MSI 00
        Capabilities: [80] MSI-X: Enable- Count=16 Masked-
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [14c] Latency Tolerance Reporting
        Capabilities: [154] L1 PM Substates
        Kernel modules: iwlwifi

It works just fine in Windows. I have tried reinstalling Manjaro, using kernel versions 5.9, 5.10, 5.11, and 5.12, clearing the CMOS, re-flashing the BIOS, and have tried it on the Live CD. None of these things have worked. Help would be greatly appreciated. Thanks!

Disable Fast Boot in Windows 10 and restart, check it is properly disabled, then reboot to Manjaro and see if that unlocks something.

Here are many info about dual booting Manjaro [root tip] Dual boot Manjaro and Windows

Most would not apply to you as you use separate drives.

1 Like

I know this is a really confusing situation and I apologize for that. I need to try to think of a better way to write it and then edit the post.

This is not a dual boot situation. Windows 10 was only installed temporarily onto a separate drive. I pulled my primary drive when installing and using Windows for the driver test, so from a UEFI point of view, these two drives have completely different UEFI profiles.

It’s not a bad idea to get that drive back out and try disabling fast boot though; you never know what Windows will lock out for itself with that enabled.

Yes that was the point, if the issue came right after installing Windows. FastBoot specifically doesn’t actually permit a real stop of the system so maybe the hardware is in a specific state and you need to properly shut it down (which FastBoot may prevent, I don’t know, just a theory I never used Win 10 personally).

1 Like

I booted back up into the Windows disk, disabled Fast Boot and let it update (for good measure; who knows when it’ll lock things because it hasn’t finished updating completely). Sure enough, when I booted back up into my Manjaro drive, WiFi was working perfectly again! Thanks so much!

Moral of the story: The second thing everyone should do to any Windows install is disable Fast Boot. Many of your problems and woes will be cured. (The first thing is of course to hide the Cortana, “People” and Microsoft Meet buttons, and to unpin and delete MS Edge shortcuts.)

Nice! It is weird how things work sometimes.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.