Wifi refusing to connect

I’m currently running manjaro on a razer blade laptop with an Intel Wifi 6 AX200 as the wireless adapter. I can scan for networks, and even attempt to connect however it will never successfully connect to my wifi. I have used three seperate kernel versions (5.18, 5.12, and 5.10) and still run into the same problem. I have attempted to install arch believing it to be a KDE issue and still ran into the same problem on the usb.

EDIT: My hotspot does work.

Are there any other fixes for this or should I buy a panda adapter?

So probably there is problem on authentication.

Maybe related?

Ran into the same issue using a panda adapter I had laying around so it might be, I’ll try booting into a different distro tomorrow and see how it works.

Additionally how would I go about removing the wpa_supplicant package?

I don’t think you would really want to remove wpa_supplicant. It would be better to mask the service. iwd is a wpa_supplicant replacement. Note that I have not tried it, so I have no opinion on iwd.

sudo pacman -S iwd 
systemctl stop wpa_supplicant
systemctl mask wpa_supplicant
systemctl enable iwd.service


Attempted this, did not work. Not sure I did it right .

Additionally I ran into the same issue on a mint usb, would mint have the same WPA issues as arch?

Both use the same NetworkManager (only different version) and both use wpa-supplicant. If that is really your problem, then try to switch to WPA2 on the router. Then it should work.

Bug#1003907: fails to successfully associate

nmcli connection show

and replace <uuid> with the real uuid

nmcli connection show <uuid> | grep -E 'key-mgmt|pmf'

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.