Wifi Qualcom Atheros is not working in Manjaro KDE

Here is the problem:

Error No 5:

$ LANG=C errno 5
EIO 5 Input/output error

Anything blocked it or it is not properly initialized… Maybe FastBoot is enabled on the UEFI?


I disabled fast Boot in Windows 10 few days ago. But, there is no fast boot option in the bios menu when uefi is selected.
I selected legacy in bios and I disabled it there.

But, Now I face a even bigger problem manjaro boot menu doesn’t appear and Pc boots straight to Windows. This problem persists even after selecting the usual uefi in bios.

I’ve had manjaro installed in before too, but this problem happened to me before and I had to format and reinstall this version wel, that’s scary
I tried restoring previous Snapshot using timeshift, but it still would not load boot menu.

Revert that change: changing to legacy means reinstalling…

By now I’m thinking a partly working WiFi card (half of a hardware failure) and it’ll break down in Windows soon too…


1 Like

I reverted back to uefi already and did os-prober and update-grub. But still there is no way of booting onto manjaro. I faced a similair problem before formatting the disk will be somewhat depressing :frowning:

Then getting a network adapter would be a good move right? I’ll do that.
But I am more afraid of being unable to boot manjaro. What should I do now?

That’s a completely different topic, and there are a few tutorials:


1 Like

Maybe this works for you:

Its bit silly but it works follow me.
:warning: Please Install your Linux OS in EFI Mode otherwise this will not work.

  1. Go to the UEFI Settings and navigate to BOOT Menu
  2. Set the boot mode to Legacy Support and boot priority as UEFI first
  3. Things to ENABLE:
  • Fast boot → enable
  • PXE boot to LAN → enable
  • IPV4 PXE LAN first → enable
  1. In EFI priority Setting,use F6 or f5 to make it
    move EFI PXE Network (xx-xx-xx-xx-xx-xx) to first
    move your to second
  2. Don’t forget to save changes: Press F10 and select Yes

Source: Lenovo E41-25 Wifi not working only in any Linux-English Community


saw your guides, they were useful. At first, I literally thought that i am going to loose all data in this installation. This problem happened to me before ( 3 weeks ago), I asked a repairshop person and he said formatting is the way to go. But now , after some googlig, I learned to use efibootmgr. Each and everytime I switch uefi and legacy , the boot order gets reset and Any non-windows installation gets no priority in the boot list.
Assigning higher priority to manjaro and updating did the trick.

While googling , I happned to stumble upon one of your articles:

It was useful and I like how your writing style was fun and interactive :grin:

1 Like

I did just as you said. On booting I got checking (media > fail) two times.

And then… HOLY LOGOS!!! I was perplexed to see the network icon change to wifi. It is working really great.
Infact, I am writing this post using that connection.
Thanks a million, @megavolt :laughing: :grin:
I really really appreciate your help :+1:

I am curious, why did the wifi not work before? Did it not work because of being on bottom of boot priority?


Thank you everyone for helping me . You guys are so smart and kind . I learned lots of new things through this thread and I Hope to repay the community by helping other users after I gain more experience in linux.

No idea why. But the kernel messages said, as quoted above, that the driver has no access to the wireless card (I/O Error). And since that worked, I would rather think that the UEFI is buggy and does not initialize it unless it is triggered on boot time first by “PXE Network”. I believe there is a workaround for windows implemented on the UEFI, but since Linux is not officially supported, it runs into the bug and have had no access to it.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.