WiFi problem - Getting "connection interrupted, A Network Change Was Detected" regularly


#1

Hello,

Hope someone will give me a solution for this.

My wifi connection is working. But regularly I’m getting connection interrupted, A Network Change Was Detected" message and then page automatically redirected and load the webpage. Sometimes it doesn’t do that automatically and I’ve to refresh. I get this message on Google Chrome & Chromium, but I guess it’s happening on firefox too, even though on Firefox I didn’t get that message, Firefox stops loading web pages, I assume because of that wifi problem.

Note: I had this same problem with Ubuntu 18.04 LTS and Linux Mint 19 Tara on the same laptop I’m currently running Manjaro XFCE.

When I connected to the internet with ethernet cable using the same wifi router I don’t have any problems.

My wifi hardware Manjaro is shown in Settings > Manjaro Settings Manager > Hardware Configuration is “dual band wireless-ac 3165 plus bluetooth”. I can’t see as driver installed in settings. (Please see this screenshot==> https://i.imgur.com/n6QAJeL.png).

I found this link by Google and my wifi hardware listed under supported devices by iwlwifi driver. (Link==> https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networking.html).

I’m not sure iwlwifi driver is installed on my system or not.

Would someone help me to fix this problem?


#2

Does this happen mostly when there is more than one AP in the vicinity (wifi repeaters etc).


#3

Sounds like radio interference causing a connection interruption.

Check your wifi AP.

There’s unlikely to be a Manjaro-related software solution here.


#4

Thanks for the reply. Can not tell that exactly. But at night (When the connection is most speed) it doesn’t happen much. I’m going to test with another router to see whether it fix the problem.


#5

Install a wifi channel scanning utility on your cell phone to find the channels with the least interference and best signal strength. Lock the router on the best channel.


#6

Thanks for the reply. Yes, it’s not a Manjaro Specific problem. Something with the Linux generally(Hardware comfortable issue or some kind of driver issue maybe). Because before I’m switching to Linux, I used Win10, and never had that problem, same hardware, same router. I’m going to test with another router and let’s see what happens.


#7

Sounds even more like interference or contention. More people using wifi devices, or anything on the 2.4GHz spectrum (e.g. microwave ovens), will cause connection issues.

My wifi regularly drops when an aircraft flies overhead, due to interference from their navigational instruments, EW countermeasures, etc.

You could try the 5GHz band if your AP and wifi card support it and see if that helps.

Things change over time. Are you certain nothing else has changed?


#8

FWIW, my wife was getting the same error on her windows machine, whenever she used Chrome, and my desktops are all ethernet. I didn’t see that with any other browser on her machine, so I kicked chrome out, and haven’t seen it since.


#9

I switched about 3 months ago and didn’t change any hardware and don’t have any other issues, I asked from the manufacture and they said: “Linux isn’t comfortable with the device”. But Linux runs much faster and way better.


#10

Probably Firefox didn’t show that same error message, because I haven’t see it on Firefox. But on Firefox page stops loading suddenly and show a blank screen or half loaded page. So I guess same thing is happening but Firefox doesn’t show that same error.


#11

If by chance the issue is driver related you could try these steps.

Install kernel 4.20, there have been problems reported on 4.14 and 4.19 with the iwlwifi driver.

Try different driver options with these commanda:

sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod

sudo modprobe iwlwifi 11n_disable=1 swcrypto=1

Test for improvement.


#12

Thank you. I’ll try it.


#13

That isn’t what I meant. Are you sure noone else has changed their use of EM/RF-emitting equipment?

Just because it worked three months ago doesn’t mean it will still work now. Many things can change over time.

On the other hand, it could be a driver regression as @tbg has pointed out. :man_shrugging:


#14

This really smells to me like a router fault, from your descriptions. If what you have is a laptop take it to a couple of free WiFi coffee shops to test. If all OK on another router/network then you know for sure you have a router fault. I would always do that basic WiFi troubleshooting test first before anything else to confirm.


#15

Some Linux wifi drivers don’t play well with certain router hardware or router settings. Saying it works fine on Windows is rather irrelevant as the drivers are different. The router connectivity may sometimes be improved by tweaking your router settings or a firmware update.

Router setup and troubleshooting tips:


#16

I’m pretty sure, It’s not a hardware issue. It’s some kind of a driver issue on or some kind of incompatibility issue. Once I tested with another router I’ll inform here. I think that will help to figure out the issue better.


#17

The fact it works better at night when there are fewer people awake doesn’t point to external factors?

But you’re right, testing in a variety of situations will help narrow down the cause.


#18

On a recent manjaro install I fixed a similar problem with wifi just by deleting the original user ( the one nominated in setup) and replacing with the usual user rather than using that user as an optional login.


#19

Hello, Quick update. I think I probably found the solution. I did what stated in this page(https://unix.stackexchange.com/questions/397370/wireless-network-slow-speed-inconsistant-connection-intel-dual-band-wireless) as the solution and it worked for me. May be not 100%. I still got the error message like couple of times. But certainly not like before.


#20

Hi thanks for the reply, I did something else and seems to be it’s fine now. If I get the problem again, I’ll try your solution as well.