Wifi only working partially

Hi,
I am using a HP Laptop with a Realtek RTL8821CE Network Card and I am connected to my home wifi network and many websites wont work. I tried many and some worked and some not. Here are some examples:
Working:
*(dot)manjaro(dot)org
archlinux(dot)org
google(dot)de/google(dot)com

Not Working:
duckduckgo(dot)com
github(dot)com

I have Windows installed as dual-boot and there everything is working perfectly fine.
I tried restarting NetworkManager a few times, but it didn’t work. Gnome says, I am connected. I am an relatively experienced Linux user, so I can work in the terminal. If you want me to show you the output of a command, just send it to me.

Any help is highly appreciated.

Lukas

Formatted output from:

inxi -Fazy
mhwd-kernel -li

Output of “(sudo) inxi -Fazy”:

System:
  Kernel: 5.15.50-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=71e6ec76-b8fc-499e-9ce2-77353d037b5b rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Console: pty pts/1 wm: gnome-shell DM: GDM v: 42.0 Distro: Manjaro Linux
    base: Arch Linux
Machine:
  Type: Laptop System: HP product: HP Laptop 15s-fq0xxx v: N/A
    serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: HP model: 8651 v: 58.16 serial: <filter> UEFI: AMI v: F.25
    date: 03/09/2022
Battery:
  ID-1: BAT0 charge: 26.4 Wh (74.8%) condition: 35.3/35.3 Wh (100.0%)
    volts: 11.8 min: 11.6 model: HP Primary type: Li-ion serial: N/A
    status: discharging
CPU:
  Info: model: Intel Celeron N4020 bits: 64 type: MCP arch: Goldmont Plus
    built: 2017 process: Intel 14nm family: 6 model-id: 0x7A (122) stepping: 8
    microcode: 0x1E
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 112 KiB
    desc: d-2x24 KiB; i-2x32 KiB L2: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1399 high: 1461 min/max: 800/2800 base/boost: 1100/2700
    scaling: driver: intel_cpufreq governor: schedutil volts: 1.2 V
    ext-clock: 100 MHz cores: 1: 1338 2: 1461 bogomips: 4378
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel GeminiLake [UHD Graphics 600] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:3185 class-ID: 0300
  Device-2: Luxvisions Innotech HP TrueVision HD Camera type: USB
    driver: uvcvideo bus-ID: 1-6:3 chip-ID: 30c9:0013 class-ID: 0e02
    serial: <filter>
  Display: server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.2
    compositor: gnome-shell driver: X: loaded: modesetting alternate: fbdev,vesa
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-size: <missing: xdpyinfo>
  Monitor-1: eDP-1 mapped: XWAYLAND0 model: BOE Display 0x076e built: 2017
    res: 1360x768 hz: 60 dpi: 102 gamma: 1.2 size: 340x190mm (13.39x7.48")
    diag: 395mm (15.5") ratio: 16:9 modes: 1366x768
  OpenGL: renderer: Mesa Intel UHD Graphics 600 (GLK 2) v: 4.6 Mesa 22.1.2
    direct render: Yes
Audio:
  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_apl bus-ID: 00:0e.0
    chip-ID: 8086:3198 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.50-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw_8821ce v: N/A modules: rtw88_8821ce
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0
    chip-ID: 10ec:c821 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  IF-ID-2: wg0 state: unknown speed: N/A duplex: N/A mac: N/A
Bluetooth:
  Device-1: Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8
    bus-ID: 1-5:2 chip-ID: 0bda:b00a class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Drives:
  Local Storage: total: 238.47 GiB used: 24.39 GiB (10.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba
    model: KBG40ZNV256G KIOXIA size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: HP00AE00 temp: 32.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 100.78 GiB size: 98.63 GiB (97.87%)
    used: 24.33 GiB (24.7%) fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p5
    maj-min: 259:5
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 61.2 MiB (23.9%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 44.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 218 Uptime: 4m wakeups: 1 Memory: 7.58 GiB used: 2.51 GiB (33.1%)
  Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1456 lib: 360 flatpak: 0
  Shell: Zsh (sudo) v: 5.9 default: Bash v: 5.1.16 running-in: gnome-terminal
  inxi: 3.3.19

Output of “mhwd-kernel -li”:

Currently running: 5.15.50-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux515

I am sorry for all the (dot)s, but I can’t upload it properly. I would recommend you, to copy the output in a text editor and then replace (dot) with . .

I hope it helps

edit your post and click this icon in the editor:
</>
and copy the outputs there

now create this file with this command:
sudo nano /etc/modprobe.d/blacklist.conf
and inside it put these lines:
blacklist rtw88_8821ce
blacklist rtw_8821ce
save the file with: ctrl+x
install headers:
pamac install linux515-headers
install driver:
pamac build rtl8821ce-dkms-git
reboot and test

I put both of this lines in the file, but I can’t install the packages. Do you know any way of downloading the files on a different computer and then running an offline install?

what do you mean you cant install the package? and which one the headers or the dkms-git?
post the output of the commands here

I am unable to install any packages. I was able to install dkms, by downloading the .tar.zst file from the mirrors and then using pacman -U dkms... . I tried the same for linux515-headers, the following was the output:

(1/3) Arming ConditionNeedsUpdate...
(2/3) Updating module dependencies...
(3/3) Install DKMS modules
==> ERROR: Missing 5.15.59-1-MANJARO kernel modules tree for module rtl8821ce/v5.5.2_34066.20200325.

I left anything above away, because it is german.
I also tried to just install the rtl8821ce-dkms-git repo with makepkg, but it tried to download somehing, which does not work.

why are you not able to install packages, thats a bigger issue than having a partially working wifi?
i understand german…
you need to install first the kernel headers then the driver

Na wenn du deutsch kannst, kann ich ja auch deutsch schreiben. Das Problem ist, dass ich ja keine Pakete installieren kann, weil ich quasi keine Internetverbindung habe. D.h., die Manjaro-Server zur Paketinstallation gehen nicht. Was nun?

so do you have any errors when trying to install something?
connect your phone to the pc via cable and enable usb tethering in your phone…
then refresh mirrors:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu linux515-headers