WiFi on my HP laptop is very slow and ocasionally drops out

Thank you @Mirdarthos for your kind welcome and info. I’ve updated my original post as you suggest :grinning:

Thank you @megavolt I tried the first block of commands you posted:

sudo -su root
systemctl stop NetworkManager
modprobe -rv rtl8188ee
modprobe -v rtl8188ee ips=0 swlps=1 fwlps=0 aspm=0
systemctl start NetworkManager && journalctl -u NetworkManager -f

This seemed to briefly increase performance but then download and upload speeds dropped again.

I also tried disabling the powersaving in NetworkManager which I see created this file:


I’m not certain yet whether that had any impact - will keep testing. Do I simply delete that file to reverse that change?

I’m starting to think that the fluctuating speeds are more to do with my Virgin ‘SuperHub’ 3 than Manjaro or the particular wireless card in my laptop.

Many thanks,

did you try with different kernel, for example with the 5.19?
and 10-powersave.conf for this to work, you need to reboot

Hi @brahma I did read something about downgrading the kernel - haven’t tried it yet but may give it a go.

On a different note, do I literally just delete 10-powersave.conf to undo that config change?


yes you can delete it, and install the 5.10 kernel, select it in grub/advanced options and see if that helped

1 Like

Hi @brahma I tried with various different kernels and 4.19.257-1-MANJARO seems to be a slight improvement. I’m starting to lose the will though as speeds are still only about 5mbs down and 3 up :frowning: Think I’ll try a Windows 11 install and see how those speeds compare arrgghhhhhh

Ok edit my last comment - the issue does seem to be the wireless card / manjaro :frowning:

You shall clear the temporary files.

Thanks Danny how do I do this please

you could try installing a driver from aur, but first post output from:
mhwd-kernel -li && inxi -N

  1. In the search box on the taskbar, type disk cleanup, and select Disk Cleanup from the list of results. Select the drive you want to clean up, and then select OK.

This is not Windows, dear @Danny525 :man_facepalming:

Output is:

Currently running: 4.19.257-1-MANJARO (linux419)
The following kernels are installed in your system:
   * linux419
   * linux510
   * linux515
  Device-1: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169

and for info I have the 10-powersave.conf file in place.

I’ve tried each of the other installed kernels.

have you already tried to boot a live-iso and check if the connection is correct in a live-session ? If not i would recommend to test this and report if there is a difference.
there had been reported problems with the dns-resolving in the past, that might be an issue but it’s hard to give support from through the inet. please check this step with a live-iso. that would be a good starting-point.

try @Olli s advice, and the driver from aur i suggested above, you can forget about it, its 3 years old, so maybe it would not even build, and if so, it would not make a difference…

If it is really a dns problem, then I would recommend to add a dns cache service… as that solves most problems in that area. NetworkManager has not a DNS Cache by itself by default, so it will send a request to the DNS-Server of your Provider every time when it asks for the IP of a Domain.

echo -e "[main]\ndns=dnsmasq" | sudo tee /etc/NetworkManager/conf.d/10-dns.conf

and install dnsmasq if not there:

pamac install dnsmasq

Keep sure that the service is not running:

systemctl status dnsmasq
systemctl disable --now dnsmasq

since NetworkManager will start it on its own.

And restart NetworkManager:

systemctl restart NetworkManager && journalctl -b0 -f -u NetworkManager

In the log there should be now dnsmasq mentioned.

1 Like

I am guilty; I relied on one of my colleagues with this reply, and he misled me. :disappointed:

1 Like

awww thanks for trying though

OK everyone, I think this is a local wifi issue after all… I’ve noticed that while the work laptop is off, the speeds I get on this machine are much more reasonable. Seems my work laptop is just a massive resource hog. Curious that it manages to grab so much of the bandwidth. I’ll keep monitoring the situation for a few more days and then close this thread if my suspicions are confirmed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.