Wifi not working after update

wifi
broadcom

#1

Lost my wifi after updating.
Also running xfce pre 6, also no wifi.


#2

Please post the output of:

inxi -F


#3

I have a Broadcom BCM4360 wifi card.
The problem is the new networkmanager.
I rolled it back and all is well now.
The same thing was reported on Arch forum.
For the time being I am avoiding the updates for networkmanager.
Rolling it back fixed both Manjaro xfce pre6 and the Manjaro 16.06 stable.


#4

Probably it’s this one: https://bugzilla.gnome.org/show_bug.cgi?id=770456

I’ve been affected too, but the workaround of setting wifi.scan-rand-mac-address=no in the config file works fine.
Meanwhile a patch has been pushed upstream, so hopefully it won’t take long to have it fixed downstream as well.


#5

Can you elaborate on the fix/workaround please?
Need file location and exact wording of change please.
Thanks!


#6

It looks like a fix should be coming soon, but heres how to apply workaround-

sudo mousepad /etc/NetworkManager/NetworkManager.conf

add this to file:

[device]
wifi.scan-rand-mac-address=no

Save. Close.
Run

killall -SIGHUP NetworkManager

Afterwards, the first activation attempt may still fail (because it bails out on the error to change the randomized MAC address to the permanent one). Then the second attempt should succeed.


#7

Many thanks!


#8

I did that, but it didn’t work for me.

Nevertheless a downgrade of “networkmanager” to 1.2.4-1 solved the problem for me.

My setup:

Kernel: 4.4.19-1-MANJARO x86_64 (64 bit)
Card-2: Intel Wireless 7260 driver: iwlwifi