WiFi not working after update. Shows Ethernet Network (Intel Ethernet) Disconnected

drivers
xfce
network-manager

#1

As mentioned here already, after the update my WiFi is not working anymore. It shows Ethernet Network (Intel Ethernet) Disconnected in the XFCE panel.

I searched around the forum and found some possible similar issues. One is the Network Manager Megathread and another one which shares the some same symptoms is this thread.

I have gone through the both of them and couldn’t find a good enough solution. I am currently using a USB to Ethernet adapter to stay online. Can someone please help me with this?

DE: XFCE
Kernels: linux419 & linux414

$ NetworkManager --version
1.14.5dev+17+gba83251bb-1

My inxi -Nzzx information is as below:

$ inxi -Nzzx
Network: Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6
Device-2: Intel Wireless 8265 / 8275 driver: N/A port: efa0 bus ID: 04:00.0
Device-3: Realtek RTL8152 Fast Ethernet Adapter type: USB driver: r8152 bus ID: 1-2:7

What I have done so far to try and fix the issue:

  • Restarted the system, router and the NetworkManager.service.
  • Checked nano /etc/NetworkManager/NetworkManager.conf after a possible solution from a thread and found nothing inside that file. That wass really suspicious. Not sure if it was supposed to be empty.

Also, reminder, WiFi was working perfectly before the update.

Thanks in advance! :slight_smile:


#2

@jonathon - Will you be able to help me with this? I saw your Network Manager Megathread. Any help would be much appreciated. :slight_smile:


#3

Both of those adapters have had their issues lately. If you had both adapters working right before an update then likely one of three things changed.

The kernel: Install and test alternate kernels. Install kernels with Manjaro Settings Manager. Always have at least 2 kernels installed.

Your Intel firmware: try removing the new firmware if your firmware was recently updated.

Network Manager: If the other options don’t work the last resort would be to downgrade Network Manager. Partial upgrades are not officially supported on Manjaro, so I never recommend this. If you feel like attempting this yourself the information on downgrading is easily found on the forum.

To find a list of components that can affect networking that were recently upgraded, run this command:

cat /var/log/pacman.log | grep -i "d systemd (\|ed linux\|mware\|twork\|dkms ins\|a-nm\|nm-c\|ufw\|dhc\|dns\|wpa" | grep -v "head\|nvidia"  | tail -n 30

#4

I had the same issue, with these warnings appearing at boot. Downgrading all of the related packages (including kernel for 414, linux-firmware, and surprisingly not networkmanager) seems to have worked.

My question is, is this something that might be solved in future updates of those packages? Or should I not update them ever again? My adapter is a Qualcomm Atheros (QCA9337).


#5

Thanks for the reply here @latinsniper. I think I will also be doing the same if there is no future update that is going to fix this issue.

My question is, is this something that might be solved in future updates of those packages? Or should I not update them ever again? My adapter is a Qualcomm Atheros (QCA9337).

This is something that I am having doubts as well. I can go through with the current setup if the future update is going to fix this. Otherwise, I think I will have to downgrade as well.

@latinsniper - A noob question on downgrading packages (since I haven’t done one before), Is it possible for me to downgrade two versions down for a package? In this case the linux419/linux414 and the linux-firmware? I ask this question because if I am waiting for the next update and if that dowsn’t fix, I might consider downgrading the packages. but is it possible after that?

Also, I thought it was a problem with the network-manager :frowning:
That’s super useful information. Thanks! :slight_smile:


#6

Thanks for the reply @tbg.

I have two kernels installed. So let me change it and see.

Thanks! Will check with this and reply back.


#7

@tbg - Getting the below error for this one:

bash: syntax error near unexpected token `('

I tried closing the parenthesis in multiple places, but the error still persists.


#8

Sorry don’t know how I lost the matching bracket.

cat /var/log/pacman.log | grep -i "ed linux\|mware\|twork\|dkms ins\|a-nm\|nm-c\|ufw\|dhc\|dns\|wpa)" | grep -v "head\|nvidia"  | tail -n 30

#9

Well now the front one is missing. :smile:

Hold on I must be missing something it seems to work. Brilliant I must say.


#10

I’m using the downgrade package, and it lists all available versions of the package you’re trying to downgrade (I think there were 2 or 3 aside from the newest one). I’m not sure how many are kept or if you can request for the updater to keep previous versions…


#11

No, Thank you! I have not been too much into grepping :grimacing:. I should’ve been better at troubleshooting it. :sweat_smile:


#12

Great. Thanks for the info!
I remember reading somewhere that there are two or more versions that will be preserved in pacman chache?! not sure. I could be wrong. Will wait for the next update to see and then will go ahead with this.


#13

Check the driver may provide some useful info.
lspci -nnk