Wifi not visible and stop working regularly

Hello !

I am posting about an issue that I encounter more often since few weeks.
When I boot my laptop, the wifi doesn’t work. Normally, it automatically detects my router. But sometimes it just doesn’t want to research.
I fought during 30 min, before I could access to the internet and post this message.

System:    Kernel: 5.7.17-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 root=UUID=4b56714b-907e-41b9-86e8-2c7f3f81023e rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: HUAWEI product: NBLB-WAX9N v: M1010 serial: <filter> 
           Mobo: HUAWEI model: NBLB-WAX9N-PCB v: M1010 serial: <filter> UEFI: HUAWEI v: 1.05 date: 12/26/2019 
Battery:   ID-1: BAT1 charge: 45.6 Wh condition: 56.9/55.3 Wh (103%) volts: 16.4/15.3 model: Desay HB4692Z9ECW-41 type: Li-ion 
           serial: <filter> status: Discharging cycles: 31 
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M275/M280 serial: <filter> charge: 55% (should be ignored) 
           rechargeable: yes status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-10510U bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 8E (142) 
           stepping: C (12) microcode: D6 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36812 
           Speed: 688 MHz min/max: 400/4900 MHz Core speeds (MHz): 1: 600 2: 600 3: 600 4: 600 5: 600 6: 600 7: 600 8: 600 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: srbds mitigation: TSX disabled 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics vendor: QUANTA driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9b41 
           Device-2: NVIDIA GP108M [GeForce MX250] vendor: QUANTA driver: nvidia v: 440.100 alternate: nouveau,nvidia_drm 
           bus ID: 06:00.0 chip ID: 10de:1d13 
           Device-3: IMC Networks ov9734_azurewave_camera type: USB driver: uvcvideo bus ID: 1-6:3 chip ID: 13d3:56f8 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: modesetting,nvidia 
           alternate: fbdev,intel,nouveau,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 158 size: 309x173mm (12.2x6.8") diag: 354mm (13.9") 
           OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.1.6 direct render: Yes 
Audio:     Device-1: Intel vendor: QUANTA driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
           chip ID: 8086:02c8 
           Sound Server: ALSA v: k5.7.17-2-MANJARO 
Network:   Device-1: Intel Wireless-AC 9462 driver: iwlwifi v: kernel port: 6000 bus ID: 00:14.3 chip ID: 8086:02f0 
           IF: wlp0s20f3 state: up mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 32.19 GiB (6.8%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN730 SDBPNTY-512G-1027 size: 476.94 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 11110000 scheme: GPT 
Partition: ID-1: / raw size: 422.14 GiB size: 414.51 GiB (98.19%) used: 32.15 GiB (7.8%) fs: ext4 dev: /dev/nvme0n1p4 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 252 Uptime: 6m Memory: 15.39 GiB used: 1.53 GiB (10.0%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           Packages: 1383 pacman: 1379 lib: 391 flatpak: 0 snap: 4 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05 

If I do rfkill list right now :

0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

But when I didn’t had internet, the Wireless LAN was missing.
So I had to reboot several times to fix my internet I get access to the internet.
I also added


in /etc/NetworkManager/NetworkManager.conf before restarting it.

But as I am not sure if i will keep internet for long, does anyone have an idea to avoid losing internet regularly ? Or maybe any idea where this problem could comes from ?

Thank you for your time


That might be a power management problem.

Run this to disable it:

echo -e "[connection]\nwifi.powersave = 0" | sudo tee /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

and reboot.

If this is not helping, mask tlp:

sudo systemctl mask tlp && sudo systemctl mask tlp-sleep

That is not a solution, but more a debug option to see where the problem comes from.

Hope it helps :wink:

1 Like

Thank you for your answer @megavolt
For now, I still get access to the internet. If I encounter another issue, I will update this topic.

I have the same problem, the both line of commands did not work for me. Plus after the second command, the driver not working properly, the WiFi option dissapear.

I can confirm the same - wifi works great for a while after installation and then one day after rebooting it stops - more reboots don’t enable it back for me. Yeah, I also keep switching between windows / Manjaro. I usually have to reinstall Manjaro again in such case. Little annoying, but reinstall makes it work again (for a while). This happens with other linux distros too (it’s not only Manjaro).