Wifi misbehaving

I’ve got Realtek RTL8822BE 802.11q/b/g/n/ac WiFi adapter, rte_8822be driver on my laptop. Sometimes wifi just turns off saying ‘disconnected’, while inxi -N still shows both ethernet and wifi drivers present. Other times wifi adapter just straight-up disappears. Sometimes a few resets fix the problem.

  Kernel: 5.11.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64 
  root=UUID=7bd052b1-d66c-4450-bc37-7138732e6121 ro quiet udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: VivoBook 15 ASUS Laptop X570UD v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: X570UD v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X570UD.311 date: 06/14/2019 
  ID-1: BAT0 charge: 38.5 Wh condition: 38.5/48.1 Wh (80%) volts: 11.7/11.7 
  model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Not charging 
  cycles: 237 
  Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: E0 L2 cache: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 801 7: 800 8: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5917 class ID: 0300 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK 
  driver: N/A alternate: nouveau, nvidia_drm, nvidia bus ID: 01:00.0 
  chip ID: 10de:1c8d class ID: 0302 
  Device-3: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo 
  bus ID: 1-5:2 chip ID: 13d3:5a05 class ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 driver: loaded: modesetting 
  display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 dpi: 142 size: 344x193mm (13.5x7.6") 
  diag: 394mm (15.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.4 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 
  chip ID: 8086:9d71 class ID: 0403 
  Sound Server: ALSA v: k5.11.0-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8168 v: 8.048.03-NAPI modules: r8169 port: d000 
  bus ID: 02:00.0 chip ID: 10ec:8168 class ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: AzureWave 
  driver: rtw_8822be v: N/A modules: rtw88_8822be port: c000 bus ID: 03:00.0 
  chip ID: 10ec:b822 class ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8 
  bus ID: 1-8:3 chip ID: 13d3:3526 class ID: e001 serial: <filter> 
  Message: Required tool hciconfig not installed. Check --recommends 
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: f060 bus ID: 00:17.0 chip ID: 8086.282a rev: 21 
  Local Storage: total: 931.51 GiB used: 56.84 GiB (6.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: SDM2 scheme: GPT 
  ID-1: / raw size: 467.02 GiB size: 458.69 GiB (98.22%) 
  used: 56.81 GiB (12.4%) fs: ext4 dev: /dev/sda4 maj-min: 8:4 
  ID-2: /boot/efi raw size: 260 MiB size: 256 MiB (98.46%) 
  used: 31.9 MiB (12.5%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 57.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
  Processes: 216 Uptime: 15m wakeups: 1 Memory: 7.66 GiB used: 1.9 GiB (24.8%) 
  Init: systemd v: 247 Compilers: gcc: 10.2.0 clang: 11.0.1 Packages: 
  pacman: 1087 lib: 358 Shell: Bash v: 5.1.0 running in: xfce4-terminal 
  inxi: 3.3.01 

Have you tried upgrading to 5.4 LTS (Long Term Support) or 5.10 (LTS candidate) yet?


i upgraded to 5.11 hoping it would fix the issue lmao

it used to be 5.10

Had a similar issues with a realtek card on one of my desktop machines. Nothing would fix it, tried 4 or 5 different kernels, manually compiling drivers, etc. It was a usb wifi adapter, but i’m pretty sure it was the same driver (I’ve slept since then)… Anyway, I know it’s not a fix but I ended up getting an intel card and problem went away.

Yeah, that sucks
Don’t think you can switch a wifi chip in a 4-year-old laptop though

Can you try both:

  • linux54
  • linux54-rt


Yes you can, because Intel UEFI drivers are generally included in Intel Core i5-8250U machines. but before we go down that road, try the above first.


Seems like a new version of Realtek drivers that just came out and fixed the problem on kernel 5.11.

havent changed it yet, still 5-11

You’re lucky I’m an editor here, so I’ve edited that crucial information into your answer so that the next person that has the same problem as you won’t have to read the entire thread but see the following at the top:


Next time please do that yourself by clicking the 3 dots below your post and pressing the pencil as I won’t be trolling all of your posts and fixing them for you all of the time!


ah, sorry, didnt get it

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.