Wifi just stop work with no reason


I have the Dell Inc. XPS 15 9500
Intel® Core™ i9-10885H CPU @ 2.40GHz × 16

The wifi was working since 3 months without problem.
Today, after a reboot, the wifi stop working.

I don’t have a visible wifi button anymore.
I tried to reboot several times, nothing.

it just stopped working, I had not done anything special.

i tried to update the network manager to solve the problem, nothing

if I run the sudo rfkill list command, I only find the bluetooh

any idea ?

➜ ~ inxi -Fxza
Kernel: 5.15.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
root=UUID=2d186c07-70be-4d5c-8f08-d3356d0c6c33 rw quiet splash apparmor=1
security=apparmor udev.log_priority=3
Desktop: GNOME 41.4 tk: GTK 3.24.33 wm: gnome-shell dm: GDM 41.3
Distro: Manjaro Linux base: Arch Linux
Message: No device data found.
IF-ID-1: br-62e71f15fc20 state: down mac:
IF-ID-2: br-7d261d2b2a75 state: down mac:
IF-ID-3: br-b70c95309fba state: up speed: 10000 Mbps duplex: unknown
IF-ID-4: br-f46ebbcb52ea state: up speed: 10000 Mbps duplex: unknown
IF-ID-5: docker0 state: down mac:
IF-ID-6: enp0s20f0u5u1 state: unknown speed: -1 duplex: half
IF-ID-7: veth1ffc71e state: up speed: 10000 Mbps duplex: full
IF-ID-8: veth92017cf state: up speed: 10000 Mbps duplex: full

mmmh, honestly I have no idea why the wireless interfaces don’t appear, so it could be a problem with missing or damaged drivers, if they worked for you before.
Look for the drivers for your Wi-Fi antenna and if there is no result, it must be because it is not physically connected or is broken.
I hope some of this can help you.

Lastly, try ifconfig to see what info it shows you (if it doesn’t recognize the command, install it with: “sudo pacman -S net-tools”)

if ipconfig doesn’t work, try ip address as an alternative to installing net-tools

Hi @salty ,
I wonder whether you could read this post in order to solve the problem.

Dell XPS 15 9500 Killer WIFI AX1650