WiFi is not working ..I update the system last time in May and i did not the machine tell today


  1. For that to work, you need some kind of internet connection.
  2. If you did not use the machine since May, there might very well be something out-of-date and no longer available.

I say think you need to connect to the internet somehow, maybe tethering, and install those drivers. Else I’d recommend reinstalling.

1 Like

Even if your network were working, then you still wouldn’t be able to install anything from the AUR because your operating system is outdated. And without a networking connection, you cannot update your system, of course.

Manjaro is a rolling-release distribution and must be kept up-to-date. If for whatever reason you don’t want to do that, then you are better off using a fixed-point-release distribution like Debian Ubuntu, Mint, Fedora, or something similar.

That said, even an outdated system won’t suddenly lose its network connection, so whatever caused that to happen must be something you yourself did, or maybe there is a hardware problem involved.

We either way cannot offer support for a system that’s out of date. The best advice we can give you is — as @Mirdarthos says — to reinstall from a recent ISO. But even then still, it would appear that Manjaro is not the right distribution for you.


1 Like

You can try booting from usb (if that adapter worked so, maybe even downloading the most recent .iso)

Then chroot and update and build dkms.

I will try this idea

Can you tell me what are the driver should I install after connecting with internet ?

Can you tell me the commands for chroot and build dkms?

That would be a good starting point for chroot

For dkms you will have to find tutorial yourself, i have not done it. How did it work in May then?

P.s. and by the way it should work out of the box with kernel 6.1+. Maybe you should reinstall with the latest github iso, and then update and change kernel to either 6.4 or 6.1 cause 63 is eol.

1 Like

It worked :muscle: but I donot how …I just stop the network and restart again on aboot version then restart

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.