WiFi Hangs On Manjaro

It’s not my first time opening this topic, in the last weeks the WiFi connection on Manjaro hangs and in order to get it to work again I either have to reboot or restart NetworkManager. This solutions however get me from a couple of minutes to a few seconds of good connection.

Last time i was told this was intended behaviour because of DHCP lease time (???) so I tried setting a static IP with no success. Was also asked to try different kernels with no success (downgraded all down to 4.14)

Now I have a little more info to give:

It looks like when the connection hangs, all is happening is that the ARP asks again for the MAC of my router (.1 is my router, .7 is my laptop) forever (it eventually stops when NM decides to drop the connection) with no success

As I do not know why this is happening, is this a known issue with a solution? If not, would it be possible to set a static/longer-lasting route and if so can someone provide me a little guide to do so?

EDIT: Since I wrote this post I have tried setting a static ARP entry. WiFi speeds are very good, on par with the speedtest from my smartphone ( = max of its capacity). I’m keeping this discussion open in case there are better/automatic solution since I suppose this one would require setting the entry at each boot.

Maybe it is not Manjaro/network manager. Maybe the issue lies with your router and/or your modem. Have you tried resetting router to factory default and reconfiguring?

Yes. I actually say it is a Manjaro (maybe config?) problem because other machines or even dual booted Windows doesn’t seem to behave like this. I also tried switching to connman with similar results. I am actually tempted to live boot a Manjaro USB to see what happens, because I’ve been using Manjaro for a while now and this problem popped up just recently