WiFi Frequently Disconnects and prompts me for the password

Hi, I’ve been having an issue for over a month now where I have a solid WiFi signal but a few times per day the WiFi disconnects and I get the “Wi-Fi password dialog - KDE Daemon” pop-up prompting me to type in my password. Which it should already know. Here’s some terminal output. I’m happy to provide more, if someone can suggest what else would help diagnose this issue. Any ideas? Thank you.

  Kernel: 5.4.74-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=fd979e97-fda3-46fc-9367-13bb68274046 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.2 tk: Qt 5.15.1 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 2349GCU v: ThinkPad T430 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 2349GCU serial: <filter> UEFI [Legacy]: LENOVO 
  v: G1ETC1WW (2.81 ) date: 06/18/2019 
  ID-1: BAT0 charge: 33.6 Wh condition: 50.3/56.2 Wh (90%) volts: 11.4/10.8 
  model: LGC 45N1005 type: Li-ion serial: <filter> status: Discharging 
  Info: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20756 
  Speed: 1197 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1197 2: 1197 
  3: 1197 4: 1197 
  Vulnerabilities: Type: itlb_multihit status: KVM: Vulnerable 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Device-2: Chicony thinkpad t430s camera type: USB driver: uvcvideo 
  bus ID: 1-1.6:5 chip ID: 04f2:b2da 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4") 
  s-diag: 485mm (19.1") 
  Monitor-1: LVDS1 res: 1600x900 hz: 60 dpi: 131 size: 310x170mm (12.2x6.7") 
  diag: 354mm (13.9") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.2.1 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
  Sound Server: ALSA v: k5.4.74-1-MANJARO 
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e 
  v: 3.2.6-k port: 6080 bus ID: 00:19.0 chip ID: 8086:1502 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi 
  v: kernel port: efa0 bus ID: 03:00.0 chip ID: 8086:0085 
  IF: wlp3s0 state: up mac: <filter> 
  Local Storage: total: 447.13 GiB used: 41.08 GiB (9.2%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: SanDisk model: SSD PLUS 480GB size: 447.13 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 04RL scheme: MBR 
  ID-1: / raw size: 447.13 GiB size: 439.11 GiB (98.21%) 
  used: 41.08 GiB (9.4%) fs: ext4 dev: /dev/sda1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 48.0 C mobo: 0.0 C 
  Fan Speeds (RPM): cpu: 3770 
  Processes: 199 Uptime: 8h 53m Memory: 15.33 GiB used: 3.30 GiB (21.5%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 
  pacman: 1399 lib: 416 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.08

Hi Throwaway12345,
I found this solution/workaround and it seems it solved the issue on my laptop. At least I haven’t seen the wi-fi password dialog since hours, while it was very frequent on the last days.


"you have to open an empty file called wifi_rand_mac.conf on the following directory /etc/NetworkManager/conf.d/
and write the following:

Save, Close or Exit and reboot. "

thanks to @pablomhr and @j8a

I came here with the same problem. Just tried the suggested solution, I hope it works. But another question is, why has it started doing this? I’ve been running Manjaro on this laptop for probably a year without this issue. What happened to break it?


My problem started within the last two months. I wonder if it was a recent change that is causing the problem. Manjaro is awesome and this is my only problem!

It’s not letting me write to that folder even when I type in my sudo password. Frustrating. I’m still a Linux beginner so this is kind of tricky for me.

This is weird, try doing it from the live usb

I was able to get the file into the directory using the terminal command to copy. Can’t do it using Dolphin.

Now I’ll have to wait and see if the connection problem goes away.

You can use kate to create the file and then when saving it in that location it will ask you for the root password

Yeah I made the file in kate. Let me ask a very dumb question…the first line is literally: [device] ? I mean the word “device”, not replace device with my computer name?

Yes not replace device with computer name jj

Cool, got it thanks. Unfortunately I’ve had two disconnects with passsword request since the reboot…

I finally had one day with no disconnections. After lots of Googling I found what (for now) is working…
I disabled IPv6 in my network settings. I used the NetworkManager connection editor to do this (small app/download from Official Repositories).

1 Like