Wifi forever turned off

Hey,

I turned off my wifi using the fn button on my notebook (5.10.109-1-MANJARO). When I tried to turn it on several days later it didn’t work anymore (only bluetooth turns on and of by using it). I can’t see any Networks. In order to find a solution I followed the post “Wifi stopped working after reboot” (sorry I’m not allowed to insert links)


ip a

gives me

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether d0:bf:9c:22:8b:c1 brd ff:ff:ff:ff:ff:ff
    altname enp2s0
    inet 192.168.178.133/24 brd 192.168.178.255 scope global dynamic noprefixroute eno1
       valid_lft 863460sec preferred_lft 863460sec
    inet6 2001:16b8:2ce7:d300:d601:e420:4fb3:ddc2/64 scope global dynamic noprefixroute 
       valid_lft 7121sec preferred_lft 3521sec
    inet6 fe80::736c:9196:c6fd:ff1a/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wlp6s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 2c:33:7a:10:55:b7 brd ff:ff:ff:ff:ff:ff

lspci -vv

gives me

06:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
	Subsystem: Hewlett-Packard Company Device 2231
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 38
	Region 0: I/O ports at 2000 [size=256]
	Region 2: Memory at f0400000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: rtl8723be
	Kernel modules: rtl8723be

lspci -vvnn | grep -i kernel

gives me

	Kernel driver in use: rtl8723be
	Kernel modules: rtl8723be

hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status"

gives me

  Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
  Driver: "r8169"
  Device File: eno1
  Link detected: yes
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
  Model: "Realtek RTL8723BE PCIe Wireless Network Adapter"
  Driver: "rtl8723be"
  Device File: wlp6s0
  Link detected: no
    Driver Status: rtl8723be is active
    Driver Activation Cmd: "modprobe rtl8723be"
  Model: "Realtek Bluetooth Radio"
  Driver: "btusb"
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"


I guess it’s a problem with the driver. I tried searching for drivers with
pamac search rtl8723be
without any result… there is only rtl8723bu and rtl8723bs

Its an old notebook. Maybe there is no driver support anymore?

provide output from:
inxi -Fazy
and:
rfkill list

1 Like

inxi -Fazy:

System:
  Kernel: 5.10.109-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=744f7b33-ce91-4459-afad-92fc9d11e821 rw quiet
    resume=UUID=63b4d886-fa0a-4edc-b005-b53f6b5b35ce udev.log_priority=3
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Hewlett-Packard product: HP 355 G2
    v: 0992100000400010000634101 serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 22C2 v: KBC Version 86.08
    serial: <superuser required> UEFI: Insyde v: F.04 date: 06/24/2014
Battery:
  ID-1: BAT0 charge: 26.9 Wh (100.0%) condition: 26.9/26.9 Wh (100.0%)
    volts: 12.1 min: 14.8 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: full
CPU:
  Info: model: AMD A8-6410 APU with AMD Radeon R5 Graphics bits: 64 type: MCP
    arch: Puma family: 0x16 (22) model-id: 0x30 (48) stepping: 1
    microcode: 0x7030104
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 2 MiB desc: 1x2 MiB
  Speed (MHz): avg: 1080 high: 1237 min/max: 1000/2000 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 998 2: 1089
    3: 998 4: 1237 bogomips: 15974
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Hewlett-Packard
    driver: radeon v: kernel alternate: amdgpu ports: active: eDP-1
    empty: HDMI-A-1,VGA-1 bus-ID: 00:01.0 chip-ID: 1002:9851 class-ID: 0300
  Device-2: AMD Jet XT [Radeon R5 M240] vendor: Hewlett-Packard
    driver: radeon v: kernel alternate: amdgpu pcie: gen: 1 speed: 2.5 GT/s
    lanes: 4 link-max: gen: 3 speed: 8 GT/s lanes: 8 bus-ID: 01:00.0
    chip-ID: 1002:6664 class-ID: 0380
  Device-3: Realtek HP Truevision HD laptop camera type: USB
    driver: uvcvideo bus-ID: 1-1.4:4 chip-ID: 0bda:5775 class-ID: 0e02
    serial: <filter>
  Display: x11 server: X.Org v: 1.21.1.3 compositor: xfwm v: 4.16.1 driver:
    X: loaded: radeon unloaded: modesetting alternate: fbdev,vesa gpu: radeon
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 mapped: eDP model: Samsung 0x4a51 built: 2013
    res: 1366x768 hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: max: 1366x768 min: 640x480
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Kabini HDMI/DP Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:01.1 chip-ID: 1002:9840
    class-ID: 0403
  Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel
    v: kernel bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
  Sound Server-1: ALSA v: k5.10.109-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtl8723be v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 06:00.0 chip-ID: 10ec:b723
    class-ID: 0280
  IF: wlp6s0 state: down mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 2-1.1:3 chip-ID: 0bda:b001 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 931.51 GiB used: 109.95 GiB (11.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM024 HN-M101MBB
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 0001 scheme: GPT
Partition:
  ID-1: / raw-size: 922.42 GiB size: 906.86 GiB (98.31%)
    used: 109.95 GiB (12.1%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda3 maj-min: 8:3
Sensors:
  System Temperatures: cpu: 42.0 C mobo: 36.0 C
  Fan Speeds (RPM): N/A
  GPU: device: radeon temp: 41.0 C device: radeon temp: 36.0 C
Info:
  Processes: 214 Uptime: 2h 18m wakeups: 1 Memory: 6.75 GiB
  used: 2.68 GiB (39.7%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1098 lib: 325 Shell: Bash
  v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.15

rfkill list:

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no

its not even detected with rfkill… try installing different kernels: 5.15 and 5.4 LTS, and boot with each of them and see

please try this first, open a terminal and run this 2 commands:

sudo rfkill unblock all
sudo systemctl restart NetworkManager.service

In terms of wifi this changed nothing…

For 5.4 it gave me the same output for rfkill. I will try later with 5.15

Hi @Thilo ,
Welcome to the forum. Please read the following post in order to solve your problem.
rtl8723be wifi connection issues solved by antenna selection / Laptop Issues / Arch Linux Forums
The post is a bit old and complicated. I do not know whether you follow the instructions and run them on the linux54 kernel.

Afterwards, I also think that you should try to install linux515 first and see whether the problem is solved.

Regards,

Also with 5.15 I get the same output for rfkill list

first things first, use a live-iso and boot from the live system. check if your wifi works with live-system and report.

Yes in live-system it works

please read the document linked below:
https://wiki.archlinux.org/title/Network_configuration/Wireless#rtl8723ae/rtl8723be