WIFI fails time to time RTL8821ae

realtek
drivers
wifi

#1

Hi there guys, I just installed Manjaro and I’m having an issue with Wifi conection.

THe problem is it disconnects after some minutes working and it’s impossible to use my computer like this.

Hope somebody can help me. I’ve already tried this solution with no success: Wi-Fi disconnects with RTL8821AE network controller

System:    Host: marcelo-pc Kernel: 4.9.39-1-MANJARO x86_64 (64 bit gcc: 7.1.1)
           Desktop: N/A Distro: Manjaro Linux
Machine:   Device: desktop Mobo: ASUSTeK model: VM42
           UEFI: ASUSTeK (Licensed from AMI) v: 1203 date: 08/28/2015
CPU:       Dual core Intel Celeron 2957U (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 5589
           clock speeds: max: 1400 MHz 1: 1400 MHz 2: 1400 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: N/A drivers: intel (unloaded: modesetting)
           tty size: 80x16
Audio:     Card-1 Intel 8 Series HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Haswell-ULT HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.9.39-1-MANJARO
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8168 v: 8.044.02-NAPI port: e000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: 38:2c:4a:0f:13:68
           Card-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
           driver: rtl8821ae port: d000 bus-ID: 04:00.0
           IF: wlp4s0 state: down mac: 26:8a:a0:97:47:01
           Card-3: ZyDAS ZD1211B 802.11g
           driver: zd1211rw v: 1.0 usb-ID: 001-005
           IF: wlp0s20u2 state: N/A mac: N/A
Drives:    HDD Total Size: 1500.3GB (1.2% used)
           ID-1: /dev/sdb model: ST1000LM024_HN size: 1000.2GB
           ID-2: /dev/sda model: HGST_HTS545050A7 size: 500.1GB
Partition: ID-1: / size: 908G used: 9.1G (2%) fs: ext4 dev: /dev/sdb2
           ID-2: swap-1 size: 8.91GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
Sensors:   System Temperatures: cpu: 53.0C mobo: 27.8C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 138 Uptime: 21 min Memory: 1220.0/3864.5MB
           Init: systemd Gcc sys: 7.1.1
           Client: Shell (bash 4.4.121) inxi: 2.3.23 

Wifi disconnections
#2

Try kernel 4.12


#3

Thanks for your answer.:+1:

I’ve installed kernel 4.12
The connection drops almost every 5 minutes but now it reconects inmediatly. The situation has improved a little.

Any further advise?


#4

Mhh… What does dmesg say?

Also


#5

hi,
I tried updating kernel but no improve, the issue is back. I also tried the solution of rtlwifi_new and no improvement.

I’ve made a clean reinstalation of manjaro as i’m not sure about all the changes I’ve made in the system

Any other Idea to resolve this?


#6

Have you tried this?


#7

HI,

Yes I have, no improvement

I’ve been forced to use windows :anguished:


#8

How about disabling random mac ?

Place in
/etc/NetworkManager/NetworkManager.conf

[device]
wifi.scan-rand-mac-address=no

#9

Hi guys.
First of all, I want to thank cscs and mirh for their interest.
I’ve found the solution to this problem and I’d like to share with all those who may have the same issue with RTL8821ae card.
The steps I’ve followed are:

  1. Fresh Manjaro 17.0.3 KDE install.
  2. Upgrade default kernel to 4.12.10-1-MANJARO
  3. Reboot system.
  4. Update all the system (I used octopi)
  5. Reboot system.
  6. Open a terminal and write:

sudo pacman -S linux-headers

git clone http://github.com/lwfinger/rtlwifi_new.git

cd rtlwifi_new

make

sudo make install

sudo modprobe rtl8821ae

IT’S DONE! :smile_cat:

Thanks to my source: Mr. Manuel Donoso https://plus.google.com/116474085004673741471


Realtek RTL8821AE 802.11ac constant disconnections
Realtek RTL8821 AE 802.11ac
#10

After sudo pacman -S linux-headers
This was displayed:

:: There are 10 providers available for linux-headers:
:: Repository core

  1. linux316-headers 2) linux318-headers 3) linux41-headers
  2. linux412-headers 5) linux413-headers 6) linux414-headers
  3. linux44-headers 8) linux49-headers
    :: Repository community
  4. linux-rt-lts-manjaro-headers 10) linux-rt-manjaro-headers

Enter a number (default=1):

I assume you should choose the default which is 1?


#11

Depends on whatever kernels you have installed

$ mhwd-kernel -li
Currently running: 4.13.3-2-MANJARO (linux413)
The following kernels are installed in your system:
   * linux413
   * linux49

Repeat for all.


#12

I have linux412 & linux49.

There are no options given the second time though:

warning: linux412-headers-4.12.14-1 is up to date – reinstalling
resolving dependencies…
looking for conflicting packages…

Packages (1) linux412-headers-4.12.14-1

Total Installed Size: 52.93 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n]

Can I just proceed with the steps? I don’t think I’ll go back to other kernels once I have this wireless connection solved. Unless I buy a new wireless card.


#13

You can install the packages manually.

sudo pacman -S linux49-headers
sudo pacman -S linux412-headers

FYI the 412 kernel has reach EOL, you should probably remove it and install the 413 kernel.


#14

Bytheby - there is also rtlwifi_new-dkms in aur :wink:


#15

How & which files do I remove that causes the conflict?

error: failed to commit transaction (conflicting files)
rtlwifi_new-dkms: /usr/lib/firmware/rtlwifi/rtl8812aefw.bin exists in filesystem
rtlwifi_new-dkms: /usr/lib/firmware/rtlwifi/rtl8812aefw_wowlan.bin exists in filesystem
Errors occurred, no packages were upgraded.
==> WARNING: Your packages are saved in /tmp/yaourt-tmp-miyazaki

Press any key to continue…

Am trying this solution since the previous solution doesn’t work apparently.


#16

#17

And in case you are not familiar here is some info on 'dkms’
https://wiki.archlinux.org/index.php/Dynamic_Kernel_Module_Support


#18

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.