Wifi drops repeatedly

Isn’t it today that my wifi has some problem with Manjaro

But this time I’m not sure if it was some configuration I made or just a bad route from my internet provider

The posts were deleted, but I had already reported problems with previous versions of Manjaro. The solution was to configure the system to ignore IPV6.

Actually wifi without IPV6 is more stable, if I set on automatic wifi does not work, because it falls at all times

My network doesn’t have IPV6, I can certify that because I checked the network with another notebook with windows and smartphones too. But I don’t use it.

There’s something in Manjaro that makes the connection drop all the time. I suspect IPV6 but it could be anything, the Qualcomm Atheros card doesn’t have many positive feedbacks…

If someone can help me I’m grateful

System details
System:    Kernel: 5.7.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 dm: SDDM 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: S400CA v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: S400CA v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: S400CA.210 date: 01/27/2014 
Battery:   ID-1: BAT0 charge: 34.3 Wh condition: 35.7/45.3 Wh (79%) volts: 11.2/11.2 
           model: ASUSTek X402--40 type: Li-ion serial: N/A status: Unknown cycles: 450 
CPU:       Topology: Dual Core model: Intel Core i5-3317U bits: 64 type: MT MCP 
           arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 13574 
           Speed: 1504 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 1195 2: 1188 3: 1201 
           4: 1261 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: ASUSTeK driver: i915 
           v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
           Device-2: Chicony UVC 1.00 device HD UVC WebCam type: USB driver: uvcvideo 
           bus ID: 1-1.2:3 chip ID: 04f2:b354 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: intel resolution: 
           1: 1366x768~60Hz 2: 1366x768~60Hz s-dpi: 96 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 20.1.5 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
           Sound Server: ALSA v: k5.7.14-1-MANJARO 
Network:   Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: AzureWave 
           driver: ath9k v: kernel port: f040 bus ID: 02:00.0 chip ID: 168c:0032 
           IF: wlp2s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros AR8161 Gigabit Ethernet vendor: ASUSTeK driver: alx 
           v: kernel port: e000 bus ID: 03:00.0 chip ID: 1969:1091 
           IF: enp3s0 state: down mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 689.33 GiB used: 88.75 GiB (12.9%) 
           ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB speed: 6.0 Gb/s 
           serial: <filter> rev: B1D2 scheme: GPT 
           ID-2: /dev/sdb type: USB vendor: JMicron Tech model: Generic size: 465.76 GiB 
           serial: <filter> rev: 0508 scheme: GPT 
Partition: ID-1: / size: 42.71 GiB used: 32.21 GiB (75.4%) fs: ext4 dev: /dev/sda2 
           ID-2: /home size: 174.21 GiB used: 56.54 GiB (32.5%) fs: ext4 dev: /dev/sda3 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 69.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 4000 
Info:      Processes: 228 Uptime: 57m Memory: 7.67 GiB used: 2.27 GiB (29.6%) Init: systemd 
           v: 245 target: graphical.target Compilers: gcc: 10.1.0 clang: 10.0.1 Packages: 1735 
           pacman: 1713 flatpak: 20 snap: 2 Shell: fish v: 3.1.0-444-g23339ae15 default: Bash 
           v: 5.0.18 running in: konsole inxi: 3.1.05 

To disable IPv6 completely just add this to boot params:

ipv6.disable=1
1 Like

In /etc/default/grub or /etc/sysctl.d/40-ipv6.conf like here?

in /etc/default/grub on the GRUB_CMDLINE_LINUX line then run
sudo update-grub
(and reboot)

2 Likes

Setting GRUB_CMDLINE_LINUX="ipv6.disable=1" solves the issue, I tested for hours and drop only one time.

Good to hear.
I used to have a similar card … so let me show you one of the things I always did on that:

In file /etc/modprobe.d/ath9k.conf (create if not present)

options ath9k nohwcrypt=1

This command would do it in one shot:

echo -e "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf

Explanation:
It passes an option to the wireless module you’re using [ath9k]
“nohwcrypt” = No Hardware Decryption
“1” = Enables this option
You will still have encryption but it will be done software side instead of hardware.

Reason: Just gave better results. Normally I chase ‘hardware acceleration’ on everything else. But finnicky radio cards? … no. If they are weird and we can offload the work it usually ends up better.

This is one parameter I already set up in last post ‘-’. So this is already created. By the way you help me in that post LoL

That’s it, problem solved! Some “networks features” for me, get in the way than help.

1 Like

After some more tests, I confirm some instability with the system. Randomly there is still a drop. Can be my wifi card?

Possible.
But there are other things to try…
You have bluetooth, right? Do you use it? Can you check stability with it disabled?

I do not have bluetooth

Hm. OK … 2 more module options that might be somewhat helpful:

bt_ant_diversity=1 ps_enable=0

(you can add them to the same options line in the modprobe file like above with nohwcrypt)
The first one may or may not have any effect - it is intended to increase wifi performance at the cost of disabling bt, and the second is making sure power savings is disabled.

1 Like

Got it, I added the parameters and rebooted in the line, I’m checking if it will happen again.
in case it happens I’ll report here again

so I thank you for your quick response and help

you may have a look here too

https://wiki.archlinux.org/index.php/IPv6

Yes, I’ve read the documentation, so I assumed at first that one of the prime suspects is the IPV6.

this article is what I quoted above

but can be other things like ISP , router or card. If you are interested this is the old post that I related in old manjaro version

But this last parameter maybe can solve this issue definitely, i need to test first

didn’t work , same thing happened

Screenshot_20200819_194838
Screenshot_20200819_194857

re-reading the old post I did, I’m not surprised I didn’t get a positive result

it is really being difficult to perform remote activities with this kind of stability that Atheros is performing

Using dmesg I encontred this errors:

[ 3520.921026] i915 0000:00:02.0: [drm] *ERROR* Atomic update failure on pipe A (start=178184 end=178185) time 227 us, min 763, max 767, scanline start 762, end 772                                  
[ 3715.133301] wlp2s0: authenticate with 0c:80:63:ca:0a:49
[ 3715.154134] wlp2s0: send auth to 0c:80:63:ca:0a:49 (try 1/3)
[ 3715.208591] wlp2s0: authenticated
[ 3715.211145] wlp2s0: associate with 0c:80:63:ca:0a:49 (try 1/3)
[ 3715.241491] wlp2s0: RX AssocResp from 0c:80:63:ca:0a:49 (capab=0x411 status=0 aid=3)
[ 3715.241664] wlp2s0: associated
[ 4098.670114] wlp2s0: authenticate with 0c:80:63:ca:0a:49
[ 4098.690475] wlp2s0: send auth to 0c:80:63:ca:0a:49 (try 1/3)
[ 4098.965447] wlp2s0: send auth to 0c:80:63:ca:0a:49 (try 2/3)
[ 4099.163735] wlp2s0: send auth to 0c:80:63:ca:0a:49 (try 3/3)
[ 4099.174047] wlp2s0: authentication with 0c:80:63:ca:0a:49 timed out
[ 4100.679230] wlp2s0: authenticate with 0c:80:63:ca:0a:49
[ 4100.698619] wlp2s0: send auth to 0c:80:63:ca:0a:49 (try 1/3)
[ 4100.738299] wlp2s0: authenticated
[ 4100.741797] wlp2s0: associate with 0c:80:63:ca:0a:49 (try 1/3)
[ 4101.149883] wlp2s0: associate with 0c:80:63:ca:0a:49 (try 2/3)
[ 4101.211607] wlp2s0: RX AssocResp from 0c:80:63:ca:0a:49 (capab=0x411 status=0 aid=3)
[ 4101.211756] wlp2s0: associated
[ 4226.689433] wlp2s0: authenticate with 0c:80:63:ca:0a:49
[ 4226.708780] wlp2s0: send auth to 0c:80:63:ca:0a:49 (try 1/3)
[ 4227.342763] wlp2s0: authenticated
[ 4227.345271] wlp2s0: associate with 0c:80:63:ca:0a:49 (try 1/3)
[ 4227.377503] wlp2s0: RX AssocResp from 0c:80:63:ca:0a:49 (capab=0x411 status=0 aid=3)
[ 4227.377683] wlp2s0: associated
[ 4232.523921] audit: type=1111 audit(1597876949.748:131): pid=576 uid=0 auid=4294967295 ses=4294967295 msg='op=statistics arg="refresh-rate-ms" pid=1466 uid=1000 result=success exe="/usr/bin/NetworkManager" hostname=? addr=? terminal=? res=success'
[ 4234.776494] audit: type=1111 audit(1597876952.001:132): pid=576 uid=0 auid=4294967295 ses=4294967295 msg='op=device-disconnect interface="wlp2s0" ifindex=3 pid=1466 uid=1000 result=success exe="/usr/bin/NetworkManager" hostname=? addr=? terminal=? res=success'
[ 4234.812098] audit: type=1130 audit(1597876952.034:133): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 4234.885117] wlp2s0: deauthenticating from 0c:80:63:ca:0a:49 by local choice (Reason: 3=DEAUTH_LEAVING)
[ 4234.887728] audit: type=1111 audit(1597876952.111:134): pid=576 uid=0 auid=4294967295 ses=4294967295 msg='op=statistics arg="refresh-rate-ms" pid=1466 uid=1000 result=success exe="/usr/bin/NetworkManager" hostname=? addr=? terminal=? res=success'
[ 4241.381319] audit: type=1111 audit(1597876958.604:135): pid=576 uid=0 auid=4294967295 ses=4294967295 msg='op=connection-activate uuid=de4af258-996f-4d08-ac94-0c451d25e733 name="ovelha_negra" pid=1466 uid=1000 result=success exe="/usr/bin/NetworkManager" hostname=? addr=? terminal=? res=success'

this is definitely related to what’s happening

In Live USB (manjaro 20.0.3) the WiFi seems to not drop