Wifi does not work: TP-Link AC1750 Archer T8E PCI Express Adapter

Hi!

First off all, I am new to Manjaro and Linux, I really appreciate detailed explanation because of this.

I installed Manjaro as a dual boot together with Windows 10.

My problem is that the wifi does not work at all. I don’t know if my network card i supported by Linux, would be happy if someone could help to check it out.

I don’t have cable right now, is there a way to install everything I need without internet connection directly on Manjaro, for example through Virtual Box or Windows 10 on another machine?

As I said at the biginning I am totally new to this, so please tell me if you guys need some more information about the problem.

Please post:

inxi -Fxxxz
hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status" 

Please post all terminal commands as text with code tags, (not as pics).

Information on how to properly post hardware specs and logs:

Please format any terminal output with three backticks before and after, as shown in this picture:

there’s only one version of this card so definitely it’s broadcom BCM4360

Probable Linux driver
should work with Broadcom’ s latest wl driver
6.30.223.30 is available in…
broadcom-wl packages (w/ dkms) or w/ no dkms) from AUR
PCI ID not yet observed in any mainline kernel / this list

A lot of people have been experiencing issues with the wl driver on recent kernels. So it might be worth testing out different kernels along with the kernel modules if the wl driver is not working.

It could be complicated trying other kernels as per installing the necessary broadcom-wl without a LAN cable though unless they have a mobile and USB cable they could hook up to use the data connection from :man_shrugging:

edit - just a thought, is broadcom-wl available as part of the non-free boot mode from the live ISO? if so, it may work with architect long enough to install manjaro with kernel 4.14 instead of 4.19

The default in live mode for most broadcom wifi is the kernel modules. Not sure if it would be possible to enable the wl driver in live mode.

I am still a little bit confused about how to solve this issue?
You guys think I should try a different kernel, and this is not possible without internet connection?

I attached some of the information you asked for, don’t know if you still need it though!

[name@name Desktop]$ inxi -Fxxxz
System:
  Host: name Kernel: 4.19.13-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN tk: Gtk 3.24.2 info: xfce4-panel 
  wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: Z170 PRO GAMING v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 0231 date: 07/17/2015 
CPU:
  Topology: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP 
  arch: Skylake-S rev: 3 L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 64152 
  Speed: 4400 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 4400 2: 4400 
  3: 4401 4: 4400 5: 4400 6: 4400 7: 4400 8: 4400 
Graphics:
  Device-1: NVIDIA GM204 [GeForce GTX 980] vendor: Gigabyte driver: nouveau 
  v: kernel bus ID: 01:00.0 chip ID: 10de:13c0 
  Display: x11 server: X.Org 1.20.3 driver: nouveau unloaded: modesetting 
  alternate: fbdev,nv,vesa resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: NV124 v: 4.3 Mesa 18.3.1 direct render: Yes 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio 
  vendor: ASUSTeK Sunrise Point-H driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 chip ID: 8086:a170 
  Device-2: NVIDIA GM204 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fbb 
  Device-3: Sennheiser type: USB driver: hid-generic,snd-usb-audio,usbhid 
  bus ID: 3-1.1:3 chip ID: 1395:005d serial: <filter> 
  Sound Server: ALSA v: k4.19.13-1-MANJARO 
Network:
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k 
  port: f000 bus ID: 00:1f.6 chip ID: 8086:15b8 
  IF: enp0s31f6 state: down mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network 
  Adapter 
  driver: bcma-pci-bridge v: N/A port: e000 bus ID: 03:00.0 
  chip ID: 14e4:43a0 
Drives:
  Local Storage: total: 3.18 TiB used: 5.92 GiB (0.2%) 
  ID-1: /dev/sda vendor: Crucial model: CT500MX200SSD1 size: 465.76 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: MU02 scheme: GPT 
  ID-2: /dev/sdb vendor: Seagate model: ST3000DM001-1ER166 size: 2.73 TiB 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC25 scheme: GPT 
Partition:
  ID-1: / size: 68.55 GiB used: 5.92 GiB (8.6%) fs: ext4 dev: /dev/sda7 
  ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 35 C 
  Fan Speeds (RPM): cpu: 0 gpu: nouveau fan: 1226 
Info:
  Processes: 224 Uptime: N/A Memory: 31.34 GiB used: 738.1 MiB (2.3%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 
  running in: xfce4-terminal inxi: 3.0.28 
[name@name Desktop]$ hwinfo --netcard --wlan --bluetooth | grep -Ei "model:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status"
  Model: "Broadcom BCM4360 802.11ac Wireless Network Adapter"
  Driver: "bcma-pci-bridge"
    Driver Status: bcma is active
    Driver Activation Cmd: "modprobe bcma"
  Model: "Intel Ethernet Connection (2) I219-V"
  Driver: "e1000e"
  Device File: enp0s31f6
  Link detected: no
    Driver Status: e1000e is active
    Driver Activation Cmd: "modprobe e1000e"
  Model: "Cambridge Silicon Radio Bluetooth Dongle (HCI mode)"
  Driver: "btusb"
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"

Run the set of commands below to see if your connection can be properly initiated.

Please do not cut and paste all the commands together at once.

Enter and run each command separately with a few seconds between each command.

Please post all inputs, and all outputs of that sequence of commands once they are finished being run.

Please do not give me a summary, such as “there were no outputs”.

It is very important that you post each input and output for troubleshooting purposes.

nmcli networking off

sudo systemctl stop NetworkManager

sudo ip link set enp0s31f6 down

sudo modprobe -r e1000e

sudo modprobe -r b43

sudo modprobe -r b43legacy

sudo modprobe -r ssb

sudo modprobe -r brcmsmac

sudo modprobe -r bcma

sudo modprobe -r wl

sudo modprobe -r brcmfmac

sudo modprobe -r btusb

sudo modprobe brcmfmac

sudo  rfkill unblock all

sudo systemctl start NetworkManager

nmcli networking on

Here is the set of commands, the only thing that gave me output was:

Desktop $sudo modprobe -r wl
modprobe: FATAL: Module wl not found.

Rest of the commands below:

Desktop $nmcli networking off
Desktop $sudo systemctl stop NetworkManager
[sudo] password for name: 
Desktop $sudo ip link set enp0s31f6 down
Desktop $sudo modprobe -r e1000e
Desktop $sudo modprobe -r b43
Desktop $sudo modprobe -r b43legacy
Desktop $sudo modprobe -r ssb
Desktop $sudo modprobe -r brcmsmac
Desktop $sudo modprobe -r bcma
Desktop $sudo modprobe -r wl
modprobe: FATAL: Module wl not found.
Desktop $sudo modprobe -r brcmfmac
Desktop $sudo modprobe -r btusb
Desktop $sudo modprobe brcmfmac
Desktop $sudo rfkill unblock all
Desktop $sudo systemctl start NetworkManager
Desktop $nmcli networking on

Was there any changes in wifi.

Please post the output of the following commands:

hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status" 
lspci -knnvvv | grep -i net
lsmod | sort 
grep -r "blacklist\|install\|options"  /etc/modprobe.d/           

I am not sure if there was any changes to be honest, but the wifi does not work.
I am new to linux, and I really don’t know where to start, especially when I do not have internet.

Desktop $hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status"
  Model: "Broadcom BCM4360 802.11ac Wireless Network Adapter"
  Driver: "bcma-pci-bridge"
    Driver Status: bcma is active
    Driver Activation Cmd: "modprobe bcma"
  Model: "Intel Ethernet Connection (2) I219-V"
  Driver: "e1000e"
  Device File: enp0s31f6
  Link detected: no
    Driver Status: e1000e is active
    Driver Activation Cmd: "modprobe e1000e"
  Model: "Cambridge Silicon Radio Bluetooth Dongle (HCI mode)"
  Driver: "btusb"
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"
Desktop $lspci -knnvvv | grep -i net
00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (2) I219-V [8086:15b8] (rev 31)
	Subsystem: ASUSTeK Computer Inc. Ethernet Connection (2) I219-V [1043:8672]
03:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)
	Subsystem: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter [14e4:0619]
Desktop $lsmod | sort
aesni_intel           200704  2
aes_x86_64             20480  1 aesni_intel
agpgart                49152  3 ttm,nouveau,drm
ahci                   40960  3
asus_wmi               32768  1 eeepc_wmi
b43                   450560  0
bcma                   61440  1 b43
bluetooth             655360  41 btrtl,btintel,btbcm,bnep,btusb,rfcomm
bnep                   24576  2
btbcm                  16384  1 btusb
btintel                24576  1 btusb
btrtl                  16384  1 btusb
btusb                  53248  0
cfg80211              778240  2 b43,mac80211
cmac                   16384  1
coretemp               16384  0
crc16                  16384  2 bluetooth,ext4
crc32c_generic         16384  0
crc32c_intel           24576  2
crc32_pclmul           16384  0
crct10dif_pclmul       16384  0
cryptd                 28672  3 crypto_simd,ghash_clmulni_intel,aesni_intel
crypto_simd            16384  1 aesni_intel
crypto_user            16384  0
drm                   495616  5 drm_kms_helper,ttm,nouveau
drm_kms_helper        208896  1 nouveau
e1000e                282624  0
ecdh_generic           24576  2 bluetooth
eeepc_wmi              16384  0
evdev                  24576  24
ext4                  733184  1
fat                    81920  1 vfat
fb_sys_fops            16384  1 drm_kms_helper
fscrypto               32768  1 ext4
fuse                  118784  3
ghash_clmulni_intel    16384  0
glue_helper            16384  1 aesni_intel
hid                   139264  3 usbhid,hid_corsair,hid_generic
hid_corsair            16384  0
hid_generic            16384  0
i2c_algo_bit           16384  1 nouveau
i2c_i801               32768  0
input_leds             16384  0
intel_cstate           16384  0
intel_powerclamp       16384  0
intel_rapl             24576  0
intel_rapl_perf        16384  0
intel_uncore          135168  0
ip_tables              28672  0
irqbypass              16384  1 kvm
iTCO_vendor_support    16384  1 iTCO_wdt
iTCO_wdt               16384  0
jbd2                  126976  1 ext4
joydev                 24576  0
kvm                   737280  1 kvm_intel
kvm_intel             245760  0
libahci                40960  1 ahci
libata                278528  2 libahci,ahci
mac80211              929792  1 b43
mac_hid                16384  0
mbcache                16384  1 ext4
mei                   114688  1 mei_me
mei_me                 45056  0
mmc_core              176128  2 b43,ssb
Module                  Size  Used by
mousedev               24576  0
mxm_wmi                16384  1 nouveau
nls_cp437              20480  1
nls_iso8859_1          16384  1
nouveau              2187264  1
pcbc                   16384  0
pcc_cpufreq            16384  0
pcmcia                 69632  1 ssb
pcmcia_core            28672  1 pcmcia
pcspkr                 16384  0
rfcomm                 86016  16
rfkill                 28672  6 asus_wmi,bluetooth,cfg80211
rng_core               16384  1 b43
scsi_mod              253952  2 sd_mod,libata
sd_mod                 61440  4
snd                    98304  26 snd_hda_codec_generic,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_usb_audio,snd_usbmidi_lib,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm,snd_rawmidi
snd_hda_codec         151552  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_codec_generic    86016  1 snd_hda_codec_realtek
snd_hda_codec_hdmi     57344  1
snd_hda_codec_realtek   118784  1
snd_hda_core           94208  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hda_intel          45056  5
snd_hwdep              16384  2 snd_usb_audio,snd_hda_codec
snd_pcm               131072  5 snd_hda_codec_hdmi,snd_hda_intel,snd_usb_audio,snd_hda_codec,snd_hda_core
snd_rawmidi            36864  1 snd_usbmidi_lib
snd_seq_device         16384  1 snd_rawmidi
snd_timer              36864  1 snd_pcm
snd_usb_audio         258048  2
snd_usbmidi_lib        32768  1 snd_usb_audio
soundcore              16384  1 snd
sparse_keymap          16384  1 asus_wmi
ssb                    90112  1 b43
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
ttm                   126976  1 nouveau
uinput                 20480  0
usbhid                 57344  0
vfat                   24576  1
wmi                    28672  4 asus_wmi,wmi_bmof,mxm_wmi,nouveau
wmi_bmof               16384  0
x86_pkg_temp_thermal    16384  0
xhci_hcd              266240  1 xhci_pci
xhci_pci               16384  0
x_tables               45056  1 ip_tables
Desktop $grep -r "blacklist\|install\|options" /etc/modprobe.d/
rfkill list all
Desktop $rfkill list all
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
Desktop $

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by