Wifi can't be connected anymore

Okay I know what the problem is, I just spent all day trying to find a solution or workaround and can’t find any.

The problem: I use KDE with a highly customized Compiz/Cairo Dock desktop. It has always worked great for me, the only thing is many of the widgets/applets don’t work but I don’t need them anyway. That is till recently. Because KDE has moved the gui for scanning and connecting to wifi completely to to the widget/applet that has never worked ion my case. This used to be no problem because you could do those tasks in the connections tab in the system menu. Some one has found it a good idea to remove that backup control for wife connection from the connections page. And here we are. I have spent all day to try to find another way to access the wifi on my laptop but no success as of yet. There must be some way to activate the wifi part of the connections manager tab like it used to without that widget/applet I think but how?

So you are using compiz as a compositor/window manager instead of kwin?

Makes sense.

Theres really almost no point to running kde at that point.

It was never really a ‘backup’ connection manager.
Really just a duplication of function - hence probably why it was removed.

You can use any of the number of network manager applets that are not plasma …
I’m sure nmcli is already present and will work in the terminal
And … you probably have had plasma-nm this whole time, while not really using plasma desktop any more … and there are plenty of gtk nm applets. . like network-manager-applet