Wifi canon printer setup?

just found manjaro for use on my surface pro type laptop that actually found and uses the network wifi and i am loving it. However, not having much luck getting a canon mx925(wifi) printer to work.
Have tried printers in system settings and there is a mx 925 to choose but when printing a test page it just says cant find printer.

many thanks.

Hello and welcome,

In order to print and scan with my Canon MX925 multifunction device, the following AUR packages have to be installed in this order:

So, you run from terminal, or just Pamac UI:
pamac build cups-bjnp
pamac build canon-pixma-mx920-complete

In addition, ghostscript must be installed to run the test print, but i think that comes installed by default already.

hello and thanks for reply…
i am new to this so please go easy on me…do i just run the 2 commands, one after the other.
Also, a text editor comes up…what do i do with that ?

many thanks.

Indeed, you run those commands, provide the password when asked, do not edit the packages, just say no to that point, and continue the install.

I’ve just gone through the process of reading through the documentation in order to set up printers for the first time myself. Cups has a very user friendly interface so I don’t think you’ll have much trouble using it. Go by their instructions for setup, i.e.

To get a list of printers on your network, including their URI use

lpinfo -v

Find the printer you want, preferably the protocol listed with dnssd: over ipp:, and add it with

lpadmin -p printername_ofyourchooice -v device_URI -E

The -E at the end will enable it to accept print jobs. Then you can go to localhost:631 in a web browser, if not already there, and over to the printers tab to ensure your printer is there and accepting prints. Try out a test page and check that everything’s in order.

Hope this helps.

hello and thanks for the information…
i tried lpinfo -v but no printers are visable…will that lpinfo “find” printers over wifi, as that is what i am trying to do ?

Thanks again.

It should indeed find all printers on the network. Ensure your printer is connected to your LAN or WLAN by checking the ‘connected devices’ page of your routers admin page. If you’ve gone through the WPS button setup it should be connected, but sometimes it needs another powercycle. Here’s an example of the output I get when I run it, the bottom three entries are all the same printer detected with three different protocols. With “dnssd://Canon%20MX470%20series._ipp._tcp.local/” being the URI you’d use in the lpadmin command.

~ >>> lpinfo -v
file cups-brf:/
network beh
direct hp
file cups-pdf:/
network https
network ipp
network lpd
network socket
network http
network ipps
network smb
direct hpfax
network dnssd://Canon%20MX470%20series._ipp._tcp.local/?uuid=00000000-0000-1000-8000-F481480182DF
network cnijbe://Canon/?port=net&serial=F4-81-72-01-82-DF
network ipp://Canon%20MX470%20series._ipp._tcp.local/

This might be a longshot, but if you still can’t get the output you want from lpinfo, try the lpadmin command with this URI. Replacing the 920 with 925 if that doesn’t work. I’m doubtful it would work if you can’t see it in lpinfo, but its worth a shot.


just to be clear…my printer is on wifi not networked…does this matter ?

Nope, that’s what your going for, lpinfo should pick up wifi printers, as long as the printer and computer your running cups on is on the same network.