WiFi and soft lockup issues in Acer Nitro 5


#61

its downloading the kernel rightnow , will do this when its finished


#62

If the commands I posted earlier don’t improve things or there are negative side effects reboot. Then try this:

sudo rmmod dell_wmi_descriptor
sudo rfkill unblock all
sudo systemctl stop NetworkManager; sleep 3; sudo systemctl start NetworkManager 

#63

this needs sudo right ?

rmmod acer_wmi 


#64

Yes, I just noticed I missed that and edited it.


#65

I added the rfkill command to both sets of commands I listed above. Please enter each command individually. Please post all inputs and outputs of each command.


#66
sudo rmmod acer_wmi
[sudo] password for acer: 
[acer@acer-pc ~]$ rfkill unblock all
[acer@acerpc ~]$ sudo systemctl stop NetworkManager
[acer@acer-pc ~]$ sleep 3
[acer@acer-pc ~]$ sudo systemctl start NetworkManager
[acer@acer-pc ~]$

with firmware 6 renamed , rebooting now as no change in wifi status


#67
[acer@acer-pc ~]$ sudo rmmod dell_wmi_descriptor
[sudo] password for acer: 
[acer@acer-pc ~]$ sudo systemctl stop NetworkManager
[acer@acer-pc ~]$ sleep 3
[acer@acer-pc ~]$ sudo systemctl start NetworkManager

no change in wifi issue


#68

Can you disable your Nic(s) in yout bios. Your output on your NICs was confusing because it shows 2 NICS , But one of them is not proper. Do you have dual NIC’s.

Afterwards run those two sets of commands again, then run it a third time substituting

sudo rmmod acer-wireless

After running each set of commands put the laptop into suspend. Then resume and check for any changes.


#69

The laptop has Realtek Ethernet and QC atheros Wifi afaik . And both arent working . I will see if the bios has anything for dual nic


#70

The only network related option in bios is Network boot and wake up on lan.


#71

Open any file in /etc/modprobe.d and ensure there is no reference to r8169.

Any file that contains the line:

blacklist r8169

Change to:

blacklist r8168

Save the edited conf file with root permissions, and then exit your text editor.

Then reboot and check if your wired connection is now working.

Then post this output please:

hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status" 

#72

etc/modprob.d currently has file called r8169_blacklist.conf only , containing

blacklist r8169

So i change it to

blacklist r8168  

No need to rename the file name to r8168_blacklist.conf also ?


#73

Not necessary, then reboot.


#74

Have you tried running any ping commands?

ping -c5 8.8.8.8

ping -c5 google.com

ping -c5 127.0.0.1 

ping -c5 localhost

#75

The setting address loop looped for much longer than before.

[acer@acer-pc ~]$ hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status" 
  Model: "Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter"
  Driver: "ath10k_pci"
  Device File: wlp3s0
  Link detected: no
    Driver Status: ath10k_pci is active
    Driver Activation Cmd: "modprobe ath10k_pci"
  Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
  Driver: "r8169"
  Device File: enp2s0f1
  Link detected: yes
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
    Driver Status: r8168 is not active
    Driver Activation Cmd: "modprobe r8168"
  Model: "Lite-On Bluetooth Device"
  Driver: "btusb"
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"

#76

Well at least your NIC is active now. That’s an improvement. Can you plug a lan cable in to see if you get a connection.

Rename the version 6 firmware back to it’s original name. Then move or rename any version 5 or 4 firmware present in the 6174 directory.


#77

The following was done with no tethering and only Ethernet connected while looping on setting network address

[acer@acer-pc ~]$ ping -c5 8.8.8.8
connect: Network is unreachable
[acer@acer-pc ~]$ ping -c5 localhost
PING localhost(localhost (::1)) 56 data bytes
64 bytes from localhost (::1): icmp_seq=1 ttl=64 time=0.037 ms
64 bytes from localhost (::1): icmp_seq=2 ttl=64 time=0.036 ms
64 bytes from localhost (::1): icmp_seq=3 ttl=64 time=0.039 ms
64 bytes from localhost (::1): icmp_seq=4 ttl=64 time=0.082 ms
64 bytes from localhost (::1): icmp_seq=5 ttl=64 time=0.036 ms

--- localhost ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 61ms
rtt min/avg/max/mdev = 0.036/0.046/0.082/0.018 ms
[acer@acer-pc ~]$ ping -c5 127.0.0.1 
PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.069 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.054 ms
64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.065 ms
64 bytes from 127.0.0.1: icmp_seq=4 ttl=64 time=0.033 ms
64 bytes from 127.0.0.1: icmp_seq=5 ttl=64 time=0.032 ms

--- 127.0.0.1 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 21ms
rtt min/avg/max/mdev = 0.032/0.050/0.069/0.017 ms
[acer@acer-pc ~]$ ping -c5 google.com
ping: google.com: Name or service not known
[acer@acer-pc ~]$ ping -c5 8.8.8.8
connect: Network is unreachable
[acer@acer-pc ~]$ ping -c5 localhost
PING localhost(localhost (::1)) 56 data bytes
64 bytes from localhost (::1): icmp_seq=1 ttl=64 time=0.027 ms
64 bytes from localhost (::1): icmp_seq=2 ttl=64 time=0.054 ms
64 bytes from localhost (::1): icmp_seq=3 ttl=64 time=0.036 ms
64 bytes from localhost (::1): icmp_seq=4 ttl=64 time=0.040 ms
64 bytes from localhost (::1): icmp_seq=5 ttl=64 time=0.043 ms

--- localhost ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 47ms
rtt min/avg/max/mdev = 0.027/0.040/0.054/0.008 ms

BTW i am getting 502 bad gateway on the forums frequently today . I hope this doesnt cause issues since posts are showing up late for me. I will try to post what is the current situation and what i did in every post

This is from before renaming firmwares


#78

deepin desktop environment has been having some issues and from what i can tell in general has more than the other DE’s. it looks pretty and all but the ability to customize very limited in comparison to the others.
thanks @tbg for jumping in, this issue is a bit out of my depth. i’ve been trying to write this post for 20 minutes but the forum seems to have forgotten it’s cup-o-coffee today. :sleeping:


#79

Did you go through your router settings?

Is your router on auto dhcp.

Please do not cut and paste all the commands together at once. Enter and run each command separately.

Please post all inputs, and all outputs of the sequence of commands.

sudo nmcli networking off

sudo systemctl stop NetworkManager

sudo ip link set wlp3s0 down

sudo modprobe -r ath10k_pci

sudo modprobe -r ath10k_core

sudo rfkill unblock all

sudo modprobe ath10k_pci

sudo modprobe ath10k_core

sudo rfkill unblock wifi

sudo ip link set wlp3s0 up

sudo systemctl start NetworkManager

sudo nmcli networking on

The forum is hanging with many time outs today.

We might be better to continue this tomorrow as its very hard to make progress with it constantly stalling out. If you can get through please post those outputs.


#80

You did great on this thread I’m sure in no time you’ll be doing a better job than me on the networking threads. Feel free to continue as I think I need a break anyways. Unfortunately the forum is totally bogged today.