WiFi and keyboard/mouse problems on RPi4

Hi all I just have a couple of unrelated questions:

  1. The 2 GHz wifi works just fine but it does not connect to my 5 GHz service, or even recognize it. On another RPi forum they told me only the Raspbian distros have that functionality. Is it possible to add the right drivers to Manjaro to allow me to run at full speed?

  2. I’m using a keyboard with touchpad, cheap Logitech unit, and it works but the cursor movement with the touchpad is herky-jerky, and the keys don’t respond very well either. This doesn’t happen on any other distro. The behavior is like when the battery is running low on a keyboard or mouse, but it;s not the battery. Any fix for this?


  1. Maybe it’s because of the country code. Check with crda.
  2. Maybe it’s interferrance with the wifi signals. Try “killing” the wifi connection and see if that helps.
    I’ve read some posts where the wifi makes to much noise.

From my Raspberry pi install.

COUNTRY environment variable not set.

And have a Logitech K400r keyboard as well.

You never mentioned if you were booting from a usb drive or had one connected. Interference from it will cause problems mentioned. To solve that put a usb extension cable between your drive and the pi4 board.

As mentioned installing crda and configuring it for your country sometimes helps also sometimes setting your router to use channel 4 or higher has helped with 5G.

Yes there is always a USB drive in there. I use it for a swap space, the browser cache, a few other miscellaneous things to limit writes to the card.

I’ll check to see what country code it is actually using, but I’m pretty sure this is distro related and not hardware itself because the mouse and 5G work fine with Raspbian. The combination of 64-bit, Firefox, and 5G does not seem to be available on any distro without work, but if I’m going to do the work I’d rather do it on Manjaro because I like it!