Wifi adapter is not working randomly at start

Hi all,
I have exactly the same issue.
I’ve been using manjaro without this problem for the last year with kernel 5.8.
Had to reinstall due to a disc failure and used the latest iso from the web: Manjaro x86_64 20.2.1 Nibia
After that, wifi adapter is not working randomly at start (login screen) and the “wifi” setting does not even appear on the “settings” menu list when already logged
Looks like the adapter is not “supported” but happens only randomly.
Using “lshw” i can see it listed when it is not working.
On dual boot it works with a windows OS.

I did read somewhere, this could be a kernel (5.9) issue not supporting the HW fully, so i updated to kernel 5.10 but the problem remains, also booted with 5.8 and same issue is happening, while this never happened before.
Did something else, related to this, change on 20.2.1 nibia?
Being random is driving me a bit crazy because i have no clue how to locate the problem.

This is “inxi -Fazy” output:

System:
  Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=27ba6cde-fa39-41b1-a203-b0147cd3b42c rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 3.38.2 tk: GTK 3.24.24 wm: gnome-shell dm: GDM 3.38.2.1 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Gigabyte product: Z390 AORUS ULTRA v: N/A 
  serial: <filter> 
  Mobo: Gigabyte model: Z390 AORUS ULTRA-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F7 date: 03/14/2019 
CPU:
  Info: 8-Core model: Intel Core i7-9700K bits: 64 type: MCP arch: Kaby Lake 
  note: check family: 6 model-id: 9E (158) stepping: D (13) microcode: DE 
  L2 cache: 12 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 57616 
  Speed: 800 MHz min/max: 800/4900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds mitigation: TSX disabled 
  Type: tsx_async_abort mitigation: TSX disabled 
Graphics:
  Device-1: NVIDIA TU104 [GeForce RTX 2080 SUPER] vendor: Micro-Star MSI 
  driver: nvidia v: 455.45.01 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1e81 
  Display: x11 server: X.org 1.20.10 compositor: gnome-shell driver: nvidia 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: GeForce RTX 2080 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a348 
  Device-2: NVIDIA TU104 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 chip ID: 10de:10f8 
  Sound Server: ALSA v: k5.10.2-2-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel 
  bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel 
  port: efa0 bus ID: 00:1f.6 chip ID: 8086:15bc 
  IF: eno2 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.84 TiB used: 721.63 GiB (38.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A 
  size: 953.87 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: AAGA4102 temp: 37.9 C 
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO M.2 1TB 
  size: 931.51 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 4B6Q 
Partition:
  ID-1: / raw size: 384.77 GiB size: 377.73 GiB (98.17%) 
  used: 165.38 GiB (43.8%) fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7 
  ID-2: /boot/efi raw size: 100 MiB size: 96 MiB (96.00%) 
  used: 25.1 MiB (26.2%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 33.0 C mobo: N/A gpu: nvidia temp: 30 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 25% 
Info:
  Processes: 261 Uptime: 2h 35m wakeups: 0 Memory: 15.57 GiB 
  used: 2.4 GiB (15.4%) Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 
  pacman: 1444 lib: 471 flatpak: 0 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.2.01 

Anyone has any idea what’s happening or how to locate where is the problem?
Hope having more info can help us find a solution as it seems to be the same problem.
Thanks!

Welcome at the forum, @corconegre,

don’t hijack other’s users threads, you can easily open your own thread, as I did this time for you. :wink:

Sorry, thought it would be helpful having it on the same place as the issue seemed to be the same.
Note taken!

1 Like

Not linked to your issue but you should implement a swap partition or swap file.

You might have run into this:

About dual-boot with Windows and “fast-boot” enabled source

If you have a dual-boot machine with a recent version of Windows and start seeing problems during initialization of the WiFi device when booting Linux, the problem could be due to the “fast startup” feature on Windows.

With this feature enabled, Windows don’t really shut down the entire system, but leaves things partially running so you can start the machine faster again. Try to disable this option, on Windows 10 it should be in “Control Panel→Hardware and Sound→Power Options→System Settings”. Select “Chooose what the power buttons do” to access the System Settings from the Power Options. Then disable the “Fast Startup” option in “Shutdown Settings”. This will cause Windows to fully shutdown and may solve the issue.

3 Likes

:arrow_up: This - or try to install kernel 5.4 and boot into it (Advanced Options at grub’s boot menu) to verify if it improves your situation.

sudo mhwd-kernel -i linux54

Wow, i created the partition on installation but must have messed up and did not assign it…
Did not really notice, but implemented now, thanks a lot!

This worked for me as well. Never thought about it and since Fast Boot was disabled and somehow reenabled (maybe while an major update).
WIFI now works instantly in Linux.

1 Like

The option was indeed activated in windows, as i also reinstalled it i guess it’s the default setting.
Disabled, rebooted and been testing those days, seems completly solved.

Thanks for your help!!!

Hello good people, Not Sure whether this is a new topic or Not.
Basically I have the very same issue with my Surface Pro 6 running manjaro (and the latest stable Kernel 5.10.x from Surface -linux , but with the important difference, that I don’t Dualboot. It is Manjaro only.

So Not even Sure If it ist the Kernel or Really Manjaro GNOME.

But the Symptoms are identical: on fresh Boot the wifi is Always working fine but when the Tablet goes to hibernate, in wake it randomly “disabled” WiFi and Turns on Airplane Mode.
With No way of re-enabeling the WiFi since the setting disappears.

Only reboot fixes the issue.

What do think?

UPDATE:

System:
          Kernel: 5.10.6-arch1-1-surface x86_64 bits: 64 compiler: gcc v: 10.2.0 
          parameters: BOOT_IMAGE=/boot/vmlinuz-linux-surface 
          root=UUID=d90679b2-d9a6-49a7-a350-e7eae2c7b590 rw quiet splash apparmor=1 
          security=apparmor resume=UUID=80f6661b-0d9c-40c3-be50-6039d3fb41a8 
          udev.log_priority=3 
          Desktop: GNOME 3.38.2 tk: GTK 3.24.24 wm: gnome-shell dm: GDM 3.38.2.1 
          Distro: Manjaro Linux 
        Machine:
          Type: Laptop System: Microsoft product: Surface Pro 6 
          v: D:0B:13F:5C:10P:38S:01E:0 serial: <filter> Chassis: type: 9 
          serial: <filter> 
          Mobo: Microsoft model: Surface Pro 6 serial: <filter> UEFI: Microsoft 
          v: 234.2344.769 date: 09/08/2018 
        Battery:
          ID-1: BAT1 charge: 18.9 Wh condition: 41.7/45.0 Wh (93%) volts: 7.4/7.6 
          model: DYN M1009168 type: Li-ion serial: <filter> status: Discharging 
          cycles: 130 
        CPU:
          Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
          arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10) 
          microcode: E0 L2 cache: 6 MiB 
          flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
          bogomips: 28808 
          Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
          4: 800 5: 800 6: 800 7: 800 8: 800 
          Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
          Type: l1tf 
          mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
          Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
          Type: meltdown mitigation: PTI 
          Type: spec_store_bypass 
          mitigation: Speculative Store Bypass disabled via prctl and seccomp 
          Type: spectre_v1 
          mitigation: usercopy/swapgs barriers and __user pointer sanitization 
          Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
          IBRS_FW, STIBP: conditional, RSB filling 
          Type: srbds mitigation: Microcode 
          Type: tsx_async_abort status: Not affected 
        Graphics:
          Device-1: Intel UHD Graphics 620 vendor: Microsoft driver: i915 v: kernel 
          bus ID: 00:02.0 chip ID: 8086:5917 
          Display: wayland server: X.org 1.20.10 compositor: gnome-shell driver: i915 
          note: n/a (using device driver) - try sudo/root display ID: 0 
          resolution: <missing: xdpyinfo> 
          OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.1 
          direct render: Yes 
        Audio:
          Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel 
          alternate: snd_soc_skl bus ID: 00:1f.3 chip ID: 8086:9d71 
          Sound Server: ALSA v: k5.10.6-arch1-1-surface 
        Network:
          Device-1: Marvell 88W8897 [AVASTAR] 802.11ac Wireless driver: mwifiex_pcie 
          v: 1.0 port: 3000 bus ID: 01:00.0 chip ID: 11ab:2b38 
          IF: wlp1s0 state: up mac: <filter> 
          Device-2: Marvell Bluetooth and Wireless LAN Composite type: USB 
          driver: btusb bus ID: 1-5:3 chip ID: 1286:204c serial: <filter> 
        Drives:
          Local Storage: total: 119.24 GiB used: 34.41 GiB (28.9%) 
          SMART Message: Required tool smartctl not installed. Check --recommends 
          ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: BC501 NVMe 128GB 
          size: 119.24 GiB block size: physical: 512 B logical: 512 B speed: 15.8 Gb/s 
          lanes: 2 serial: <filter> rev: 80000C00 temp: 23.9 C 
        Partition:
          ID-1: / raw size: 110.15 GiB size: 107.92 GiB (97.98%) 
          used: 34.41 GiB (31.9%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
          ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
          used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
        Swap:
          Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
          ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
          dev: /dev/nvme0n1p3 maj-min: 259:3 
        Sensors:
          System Temperatures: cpu: 23.0 C mobo: N/A 
          Fan Speeds (RPM): N/A 
        Info:
          Processes: 257 Uptime: 1m wakeups: 2 Memory: 7.7 GiB used: 2.09 GiB (27.1%) 
          Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 1303 pacman: 1297 
          lib: 405 flatpak: 6 Shell: Zsh v: 5.8 running in: gnome-terminal 
          inxi: 3.2.01