Wie Bildschirmkontrast verbessern?

Hallo,
alle Anwendungen haben bei mir sehr schlechten Kontrast (Beispiel anliegend).
Ich habe in den Einstellungen für Gnome und in einigen Anwendungen, z.B. Firefox, gesucht, aber nichts gefunden, was mir hilft. Den Montor (Phillips PHL 273V5) habe ich schon auf maximalen Kontrast gestellt.
Wie kann man den Kontrast für alle Anwendungen verbessern?

hallo @Rolf_V
du könntest die einstellung der kantengkättung ändern und schauen ob es verbesserungen bringt
https://wiki.archlinux.de/title/Schönere_Schrift_auf_TFT/LCD_Bildschirmen

ggf. auch die schriftart selbst ändern, da gibt es auch unterschiede. im notfall dort auch mal die ms-fonts nachinstallieren und auch die mal ausprobieren.

@megavolt
Hallo Elmo,
leider hat der Vorschlag von Olli nicht geholfen. Wie ich ms-fonts nachinstallieren kann, weiß ich nicht.
Nun habe ich Dein Posting vom Dezember 2020 gefunden “How to adjust screen contrast in manjaro”, in dem Du vorgeschlagen hast: “Create a file called 40-gamma.conf on the path /etc/X11/xorg.conf.d/ and put the text into it. Save it. Then it will be set permanently on every boot.”
Ich habe das gemacht, aber nach dem Booten habe ich nur noch einen schwarzen Bildschirm gesehen. Zum Glück bin ich jetzt soweit in die Tiefen des Linux und Manjaro eingestiegen, dass ich in einem Lifesystem vom USB-Stick diese Datei wieder löschen konnte.
Die andere Lösung, die jemand 2019 vorgeschlagen hatte: ‘pacman -S monica’, zeigt nur “monica nicht gefunden”

Bitte versuche, mir eine andere Lösung vorzuschlagen.
Danke im Voraus
Rolf

Teste doch mal colord
Schalte die Nachtfarben aus.
Stelle die DPI bei Schriftarten auf 81
Der sollte ja deinem am nächsten kommen

Wie ist er den angeschlossen ? VGA/HDMI ??

Vielleicht solltest du dich auch nochmal mit dem Monitor eigenen SmartContrast beschäftigen.

/IRONIE
und ganz wichtig, beachte die Betriebsbedingungen
" Höhenlage Betrieb: 3.658 m, außer Betrieb: 12.192 m "
IRONIE/

Hast du die Werte denn vorher mit xgamma oder xrandr getestet, wie beschrieben? Klingt eher nach einer fehlerhaften Konfiguration.

Und wir wissen ja, das Gnome mit Wayland und Xorg läuft. Was verwendest du denn?

Ganz generell auf Gnome zugeschnitten kann man das per ICC Profil ändern. Dazu muss ein entsprechendes Profil erstellen und importieren unter “Farben” (Color) in den Einstellungen.

Das erstellen des Profils ist nicht integriert, sodass man auf andere Lösungen zurückgreifen muss.

Hier zum Beispiel ein Terminal-Script:

curl -O https://raw.githubusercontent.com/zb3/gnome-gamma-tool/main/gnome-gamma-tool.py
python gnome-gamma-tool.py -h # <- Hilfe
python gnome-gamma-tool.py -g 0.8

Das erstellt ein modifiziertes ICC Profil in $HOME/.local/share/icc/.

Oder verwende ein Profil aus dem Internet.

https://wiki.archlinux.org/title/backlight

    ~  colord                                                           ✔ 
zsh: correct 'colord' to 'colors' [nyae]? y
    ~       

mein manjaro weiß nicht, was colord ist.

HDMI

Ich habe den Monitor so eingestellt, dass unter Windows der Kontrast und die Farbwidergabe so wie erwartet sind.

Vielleicht hilt ‘xset q’ weiter:

 ~  xset q                                                ✔  1m 12s  
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  33
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  built-ins
DPMS (Display Power Management Signaling):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
    ~                                                                   ✔ 

xgamma kennt er nicht

    ~  xgamma                                                           ✔ 
zsh: command not found: xgamma
    ~  xrandr                                                       127 ✘ 
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 336mm
   1920x1080     60.00*+  50.00    59.94  
   1920x1080i    60.00    50.00    59.94  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      74.98    59.90  
   1280x960      60.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x576i      50.00  
   720x480       60.00    59.94  
   720x480i      60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  
    ~    

Xorg

jetzt habe ich in …icc 2 Dateien:
edid-8480072e0f29fe3c57bc0cf3ac0285d1.icc
und
gnome-gamma-tool-424b586e-5ce2-4e50-a3bb-30def73db7e1

Der Kontrast ist in der Tat besser. Es wird zwar noch immer kein exaktes Schwarz-Weiß-Bild (bei Texten in LibreOffice zum Beispiel). Aber so wie es jetzt ist, genügt es mir schon.
Danke, Elmo.

1 Like

Hab jetzt mal mit dem Paketmanager xgamma installiert und im Terminal laufen lassen

    ~  xgamma                                                           ✔ 
-> Red  1.000, Green  1.000, Blue  1.000
    ~        

Mir scheint, mit xgamma kann ich nur die RGB-Werte einstellen, nicht aber den Kontrast. Im Manual steht ausserdem

 Note that the xgamma utility is obsolete and deficient,  xrandr  should
       be used with drivers that support the XRandr extension.

Aber auch bei xrandr kann ich keine Kontrasteinstellung erkennen:

    ~  xrandr -help                                              ✔  5s  
usage: xrandr [options]
  where options are:
  --display <display> or -d <display>
  --help
  -o <normal,inverted,left,right,0,1,2,3>
            or --orientation <normal,inverted,left,right,0,1,2,3>
  -q        or --query
  -s <size>/<width>x<height> or --size <size>/<width>x<height>
  -r <rate> or --rate <rate> or --refresh <rate>
  -v        or --version
  -x        (reflect in x)
  -y        (reflect in y)
  --screen <screen>
  --verbose
  --current
  --dryrun
  --nograb
  --prop or --properties
  --fb <width>x<height>
  --fbmm <width>x<height>
  --dpi <dpi>/<output>
  --output <output>
      --auto
      --mode <mode>
      --preferred
      --pos <x>x<y>
      --rate <rate> or --refresh <rate>
      --reflect normal,x,y,xy
      --rotate normal,inverted,left,right
      --left-of <output>
      --right-of <output>
      --above <output>
      --below <output>
      --same-as <output>
      --set <property> <value>
      --scale <x>[x<y>]
      --scale-from <w>x<h>
      --transform <a>,<b>,<c>,<d>,<e>,<f>,<g>,<h>,<i>
      --filter nearest,bilinear
      --off
      --crtc <crtc>
      --panning <w>x<h>[+<x>+<y>[/<track:w>x<h>+<x>+<y>[/<border:l>/<t>/<r>/<b>]]]
      --gamma <r>[:<g>:<b>]
      --brightness <value>
      --primary
  --noprimary
  --newmode <name> <clock MHz>
            <hdisp> <hsync-start> <hsync-end> <htotal>
            <vdisp> <vsync-start> <vsync-end> <vtotal>
            [flags...]
            Valid flags: +HSync -HSync +VSync -VSync
                         +CSync -CSync CSync Interlace DoubleScan
  --rmmode <name>
  --addmode <output> <name>
  --delmode <output> <name>
  --listproviders
  --setprovideroutputsource <prov-xid> <source-xid>
  --setprovideroffloadsink <prov-xid> <sink-xid>
  --listmonitors
  --listactivemonitors
  --setmonitor <name> {auto|<w>/<mmw>x<h>/<mmh>+<x>+<y>} {none|<output>,<output>,...}
  --delmonitor <name>
    ~     

Irgendwo hatte ich dann gelesen, dass jemand die Einstellungen mit monica verbessert hat. Also habe ich versucht, auch das über den Paketmanager zu installieren.
Fehleranzeige:

Vorbereitung...
Überprüfe monica Abhängigkeiten...
Abhängigkeiten werden aufgelöst...
Interne Konflikte werden überprüft...
Klone monica Build-Dateien...
Generiere monica Informationen...
http://ftp.belnet.be/mirrors/manjaro/repos/stable/extra/x86_64/gendesk-1.0.9-3-x86_64.pkg.tar.zst: Zeitüberschreitung bei Ein-/Ausgabeoperation des Sockets
http://ftp.belnet.be/mirrors/manjaro/repos/stable/extra/x86_64/fltk-1.3.9-1-x86_64.pkg.tar.zst: Zeitüberschreitung bei Ein-/Ausgabeoperation des Sockets
Herunterladen von fltk (1.3.9-1) gestartet
Herunterladen von gendesk (1.0.9-3) gestartet
Herunterladen von fltk (1.3.9-1) beendet
Herunterladen von gendesk (1.0.9-3) beendet
http://ftp.belnet.be/mirrors/manjaro/repos/stable/extra/x86_64/gendesk-1.0.9-3-x86_64.pkg.tar.zst: Zeitüberschreitung bei Ein-/Ausgabeoperation des Sockets
http://ftp.belnet.be/mirrors/manjaro/repos/stable/extra/x86_64/fltk-1.3.9-1-x86_64.pkg.tar.zst: Zeitüberschreitung bei Ein-/Ausgabeoperation des Sockets
Überprüfe Schlüsselring...
Integrität wird überprüft...
Paketdateien werden geladen...
Dateikonflikte werden überprüft...
Überprüfe verfügbaren Speicherplatz...
Installiere gendesk (1.0.9-3)...
Installiere fltk (1.3.9-1)...
Starte Post-Transaction-Hooks...
Arming ConditionNeedsUpdate...
Updating the MIME type database...
Updating icon theme caches...
Updating the desktop file MIME type cache...

Erstelle monica...
==> Erstelle Paket: monica 3.7-7 (Fr 29 Dez 2023 23:32:38 CET)
==> Prüfe Laufzeit-Abhängigkeiten...
==> Prüfe Buildtime-Abhängigkeiten...
==> Empfange Quellen...
  -> Lade monica-3.7.tar.bz2 herunter...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100 18330  100 18330    0     0    99k      0 --:--:-- --:--:-- --:--:--  100k
  -> monica.png gefunden
  -> 01_missing-string-literal.patch gefunden
==> Überprüfe source Dateien mit sha512sums...
    monica-3.7.tar.bz2 ... Erfolg
    monica.png ... Erfolg
    01_missing-string-literal.patch ... Erfolg
==> Entferne existierendes $srcdir/ Verzeichnis...
==> Entpacke Quellen...
  -> Entpacke monica-3.7.tar.bz2 mit bsdtar
==> Beginne prepare()...
[monica]                          Generating desktop file... ok
/var/tmp/pamac-build-rolf/monica/PKGBUILD: Zeile 27: patch: Kommando nicht gefunden.
==> FEHLER: Ein Fehler geschah in prepare().
    Breche ab...

Vielleicht kann mir einer von den Gurus doch noch Empfehlungen geben, wie ich die Kontraste bei XORG verbessern kann.

Keine Ahnung, wirklich. Ich verwende kein Gnome und ich kann auch nicht nachvollziehen, was du genau brauchst.

Schau mal vielleicht unter Einstellungen → Barrierefreiheit → Sehen → Hoher Kontrast. Meinst du sowas?

Wegen monica, du brauchst für inoffizelle AUR Pakete auch:

pamac install base-devel

Die Barrierefreiheit habe ich mir als Icon auf die rechte Ecke des Bildschirms geholt. Die Änderung des Kontrasts kann ich aber überhaupt nicht gebrauchen, weil mit hohem Kontrast bei Libreoffice die Farben vollkommen verschwinden:
Kontrast niedrig

Kontrast hoch

Am besten sieht man mein Problem bei Änderung der Einstellung “Erscheinungsbild”. Mit dem dunklen Stil wird in einigen Apps z.B. im Paketmanager alles exakt in schwarz/weiß dargestellt. Mit dem Vorgabestil (hell) sieht man die schwarze Farbe aber nur in grau, so dass der Text in der dritten Zeile fast nicht lesbar wird.
Dunkler Stil:


Vorgabestil:

Mit dem dunklen Stil könnte ich leben. Aber bei anderen Apps hat diese Änderung keine Auswirkung. Damit wird dann die Arbeit am PC lästig.

Vielleicht sollte ich auf eine andere Desktop-Umgebung umsteigen. Welche verwendest Du?

Ich glaube nicht, dass das an GNOME liegt. Ich hatte GNOME ne ganze Weile laufen (auf EndeavourOS mit Wayland standardmäßig). War die sauberste Schriftendarstellung, die ich mir wünschen konnte. AMD-Karte mit amdgpu-Treiber.

OK, verstehe ich, aber für das spezielle Problem, gibt es leider keine Universallösung. GTK und QT sind unterschiedliche Frameworks, die unterschiedliche Einstellungen brauchen.

Wenn es dir nur um diese konkrete Problem im Pamac geht, dann kann man das modifizieren per CSS.

Erstelle eine Datei in $HOME/.config/gtk-3.0/gtk.css und füge das ein:

.dim-label  {
	opacity: 1;
}

Das verändert die Deckungskraft für alle GTK-Programme, deren Stilklasse vermerkt ist. Dann sieht das so aus:

grafik
grafik

Durch die höhere Deckungskraft sollte der Kontrast jetzt besser sein, allerdings ist das eine Einstellung vom Entwickler, dass es gedimmt wird.

Wenn du pamac so startest kannst du die Stillklasse herausfinden:

GTK_DEBUG=interactive pamac-manager

Da öffnet sich ein zweites Fenster. Darin kannst du dann die Stillklasse für jedes Objekt herausfinden und per CSS live verändern/testen.

Mit meiner wirst du bestimmt nicht glücklich: SwayWM. Ich achte nicht groß auf Aussehen und Benutzerfreundlichkeit, sondern eher auf Funktionalität und Einfachheit.

Generell sollte man abwägen: Bei KDE/LXQT, sollte man QT-Anwendung bevorzugen, bei XFCE/GNOME/CINNAMON/BUDGIE/MATE eher GTK-Anwendungen. Allerdings kann man es auch mixen, wenn das Aussehen und Theming nicht stört.

Universal sind alle, aber total unabhängig sind I3 und SwayWM. Diese sind Fenster-Manager und keine Desktop-Umgebungen.

Erstelle dir doch mal einem MANJARO KDE Install USB Stick. Boote von diesem und schaue ob es da genau so ist.

Irgendwie vermute ich ja immer noch das es an deinen Monitoreinstellungen liegt.
Gerade wenn ich das Handbuch lese und so was finde:
"
EasyRead: Verbessert die Lesbarkeit
textbasierter Anwendungen
wie PDF-eBooks. Durch Einsatz
eines speziellen Algorithmus, der
Kontrast und Schärfe von Textinhalt
erhöht, wird die Anzeige zum
augenschonenden Lesen optimiert,
indem Helligkeit, Kontrast und
Farbtemperatur des Monitors
angepasst werden.
• Office (Büro): Verbessert die
Textdarstellung und vermindert
die Helligkeit; so können Sie
Texte besser lesen und überlasten
Ihre Augen nicht. Dieser Modus
eignet sich ganz besonders zur
Verbesserung von Lesbarkeit
und Produktivität, wenn Sie mit
Tabellenkalkulationen, PDF-Dateien
"

SmartImage und SmartContrast definitiv ausschalten bevor man am System rumspielt.