Wi-fi stopped working - hardware failure?


Today, my Wi-fi stopped working all of a sudden in the middle of a video call. All Wi-fi networks in the network menu/list disappeared.

Later in the day, after rebooting / switching users many times, wi-fi started working again for 1 hour or so. Then, the same exact problem happened and I could not detect any networks. Again, later in the afternoon, I went to university, I got to connect to its Wi-fi network and half an hour later the error repeated again.

Now I haven’t had any chance to detect any Wi-fi for some hours. The only thing I can do is to share my connection via Bluetooth from my mobile phone, and it does work well. No ethernet since my computer has no ports.

I suspect it might be a hardware issue?, but I have no idea how to troubleshoot, and I wonder if there are any ways to know the source of the error. I had previously had strange issues related to wi-fi not working when my GPU was running. My laptop is really small and I have wondered for some time that space constraints / overheat might be provoking some errors.

Anyway, if someone wants to give it a try and help me it’d be really appreciated.

Additional info:

  • NetworkManager daemon is active and running at all times.
  • I have tried to boot another Manjaro from an USB and I had the same issue there - no networks detected.
  • I have not updated any packages for some days now nor I have made any significant changes.
  • Wi-fi works fine in my phone and other devices.
  • I’ve been using Manjaro KDE for some months now, not a fresh install.
inxi -Fxxx

System:    Host: sergi Kernel: 5.10.70-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
           Desktop: KDE Plasma 5.22.5 Distro: Manjaro Linux base: Arch Linux
Machine:   Type: Laptop System: Micro-Star product: Modern 14 A10RB v: REV:1.0 serial: <superuser required>
           Mobo: Micro-Star model: MS-14B3 v: REV:1.0 serial: <superuser required> UEFI: American Megatrends
           v: E14B3IMS.50C date: 10/31/2019
Battery:   ID-1: BAT1 charge: 21.5 Wh (62.9%) condition: 34.2/50.0 Wh (68.5%) volts: 15.2 min: 15.2
           model: MSI BIF0_9 status: Discharging
           Device-1: hidpp_battery_0 model: Logitech M585/M590 Multi-Device Mouse
           charge: 55% (should be ignored) status: Discharging
CPU:       Info: Quad Core model: Intel Core i7-10510U bits: 64 type: MT MCP arch: Kaby Lake note: check
           rev: C cache: L2: 8 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36812
           Speed: 900 MHz min/max: 400/4900 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 845 5: 900 6: 901
           7: 900 8: 891
Graphics:  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Micro-Star MSI driver: i915 v: kernel
           bus-ID: 00:02.0
           Device-2: NVIDIA GP108M [GeForce MX250] driver: N/A bus-ID: 01:00.0
           Device-3: Acer HD Webcam type: USB driver: uvcvideo bus-ID: 1-7:4
           Display: x11 server: X.Org 1.20.13 driver: loaded: modesetting resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.3 direct render: Yes
Audio:     Device-1: Intel Comet Lake PCH-LP cAVS vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
           bus-ID: 00:1f.3
           Sound Server-1: ALSA v: k5.10.70-1-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
           IF-ID-1: bnep0 state: unknown speed: N/A duplex: N/A mac: c0:b8:83:f2:23:75
           IF-ID-2: docker0 state: down mac: 02:42:59:8d:5f:5d
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8
           bus-ID: 1-10:5
           Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Drives:    Local Storage: total: 476.94 GiB used: 325.6 GiB (68.3%)
           ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 476.94 GiB temp: 40.9 C
Partition: ID-1: / size: 468.16 GiB used: 325.6 GiB (69.5%) fs: ext4 dev: /dev/nvme0n1p2
           ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 261 Uptime: 31m Memory: 15.47 GiB used: 1.99 GiB (12.9%) Init: systemd Compilers:
           gcc: 11.1.0 clang: 12.0.1 Packages: 1859 Shell: Bash v: 5.1.8 inxi: 3.3.07

If booting into live CD doesn’t show you networks, then I also suspect something is wrong with the hardware. You can also try to boot into a live CD of some other distribution and check it again.

If you can still enable/disable wifi, then try to get really close to your wifi and try to detect any signal. Check if the antenna is not damaged due to opening and closing the lid.

I use to have some problems with Bluetooth not working when GPU was active. You can try to switch graphics mode and see if it changes anything.

1 Like

Today, Wi-fi has started working again in another different Wi-fi environment (the third one I’ve been in). I’m expecting it to fail at some point later, but for the moment, more than 2 hours in, it’s still on. It did not work at home today.

Unfortunately it did not help.

Tried it and it did not make any change. I am using Optimus manager.

Yes, I’ll try. I’m downloading another distro to boot it.
Thanks for your help @LyraleiBreeze!

1 Like