Why my manjaro System is consuming too much Ram on startup (2.3 Gb)?

so now open a system monitor app that you have, or run this command: htop and check what is consuming so much ram

Mega-sync Cloud application consuming 650 mb on top and then xfce system background processes…

Hello @MAdnanNaeem :wink:

I don’t think snap is the huge problem here. Please check what apps eat your ram:

ps --no-headers -o pid,user,%mem,rss,command ax | sort -b -k3 -r | head -40
LANG=C free -h

I have already uninstalled all Snap Packages LoL…

I don’t understand why Linux OS is consuming so much RAM on startup… There are small small processes running in the background.
I guess, I have to reinstall the Manjaro or switch to any other linux distro which consumes less resources … :frowning_face:

Maybe check this: https://www.linuxatemyram.com/

A fully healthy linux system uses all your ram. It caches/buffers as much as possible on the ram.

But most of the times, I need much resources to open multiple browsers with many tabs and development env.
So, My system suddenly stuck and paralyze. This is the real problem for me

I guess, I have to install this version of Manjaro ( Minimal Long Term Support Kernel with no additional software packages pre-installed ) and install the applications of daily usage…
What you think ? This will be enough to solve my problem ?

There is your problem.

The reason for that is simply that you don’t have a swap:

8 GB RAM without a swap is not enough to run 100 of firefox tabs while coding with vscode and using postman.

2 Likes

So, What i have to do now ?

you still didnt post output from htop or the megavolts command …


    0[|||                          5.9%]   4[||                           3.3%]
    1[|||                          5.2%]   5[|||                          5.8%]
    2[||||                         7.1%]   6[||||                         9.0%]
    3[|||                          5.8%]   7[||||                         9.0%]
  Mem[||||||||||||||||      1.60G/7.52G] Tasks: 130, 645 thr, 172 kthr; 1 runni
  Swp[                            0K/0K] Load average: 1.16 0.30 0.10 
                                         Uptime: 00:00:37

    PID USER       PRI  NI  VIRT   RES   SHR S CPU%▽MEM%   TIME+  Command
   2027 adnannaeem  20   0 1112G  208M  108M S 29.1  2.7  0:05.49 /opt/google/ch
    715 root        20   0 1453M 83708 55808 S  6.5  1.1  0:03.10 /usr/lib/Xorg
   2181 adnannaeem  20   0  810M 62504 46112 S  5.8  0.8  0:00.85 xfce4-terminal
   2074 adnannaeem  20   0 1112G  208M  108M S  3.9  2.7  0:00.64 /opt/google/ch
   2078 adnannaeem  20   0 1112G  208M  108M S  3.9  2.7  0:00.37 /opt/google/ch
   2029 adnannaeem  20   0 1112G  208M  108M S  3.2  2.7  0:00.52 /opt/google/ch
   2031 adnannaeem  20   0 1112G  208M  108M S  3.2  2.7  0:00.24 /opt/google/ch
   2077 adnannaeem  20   0 1112G  208M  108M S  3.2  2.7  0:00.25 /opt/google/ch
   2079 adnannaeem  20   0 1112G  208M  108M S  3.2  2.7  0:00.21 /opt/google/ch
   2080 adnannaeem  20   0 1112G  208M  108M S  3.2  2.7  0:00.22 /opt/google/ch
   2229 adnannaeem  20   0  9832  5760  3636 R  3.2  0.1  0:00.33 htop
   1759 adnannaeem  20   0 17.0G  257M  165M S  2.6  3.3  0:08.49 /opt/google/ch
   1061 root        20   0 1453M 83708 55808 S  1.9  1.1  0:00.36 /usr/lib/Xorg
F1Help  F2Setup F3SearchF4FilterF5Tree  F6SortByF7Nice -F8Nice +F9Kill  F10Quit

I would recommend a dynamic swap on a nvme:

Simply:

  1. Install systemd-swap:
pamac install systemd-swap
  1. Edit the file:
sudo nano /etc/systemd/swap.conf

uncomment the variables swapfc_enabled=1

  1. and run the service
sudo systemctl enable --now systemd-swap.service

Swap - ArchWiki

Now it creates swapfiles if needed.

1 Like

well it looks good here, it uses 1.6 gb of ram with running chrome…