Why is there a time-gap of 2 hours between default user-account and administrator account

I’m still confused and not fully ‘convinced’.

Should my conclusion be that the primary installed Manjaro account is always a root-account?
When the answer is irrefutable YES, than I’ve unintentionally used my root account without knowing. That isn’t really desirable.

But, if the root-account is only used/activated by me when explicitly asked for, than I should have used my admin account as a ‘non-root’ account (with or without sudo rights).
In this case, everything stays within acceptable security parameters…

No. The “Administrator” flag simply means that the account is permitted to run sudo. The account itself does not have root permissions though.

Wow, that’s good news for me nevertheless :grinning:
Yet one more question (answer) to go…

i think it’s firefox sync, when you stop using firefox on 1 device, it sometimes doesn’t sync right away, usually because you closed it & it waits till next it’s open.

Maybe Firefox is part of the problem. Firefox is mostly used on the same device (laptop), but through different (manjaro) user accounts, as well through standard user accounts (no sudo rights) as administrator accounts (user with sudo rights). I used to log out (from manjaro) when changing user account in the same session. So no manjaro session will be saved anyway.

So, I still keep wondering why?
It has definitely something to do with the type of account I use for that particular Firefox moment.

But, could it also be related to something else…

I reinstalled Manjaro yesterday and noticed that the timezone EU/AMS resulted in a time-gap from 2-hours difference (2 hours later in stead of legacy time). Only the manually selected (old) configuration of Etc/GMT gives me the right time for The Netherlands.

Is it a bug or something else…

In windows often the BIOS-hardware-clock is set to local timezone. This is usually not done in linux this way. In Linux you would set BIOS-hardware-clock to GMT ± 0 and linux will correct this when running to your (hopefully correctly set) local timezone.
Is it possible that this is related to your clock-issue ?

1 Like

It is correct that my laptop originally is/was a Windows 7 machine (64-bit).
For several years Windows has been replaced by whatever Linux version only, but mainly Manjaro.
The original hard disk (MBR file system) is replaced by a GPT formatted and LUKS encrypted ssd-disk.
In the BIOS the internal clock is set on LOCAL REAL time (not Etc/GMT or what else).
When I adjust local time in BIOS 2 hours earlier than local time, the ‘problem’ is also ‘solved’, but it is not the way it should be solved.
System (hardware) time should always be dominant, leading and should always be accepted by the installed operating system. So, in my opinion, EU/AMS should always show my LOCAL (BIOS) time.
If not, there is somehow/somewhere a flaw/bug or the software/configuration of Manjaro is corrupted.

So, the question remains, why does Manjaro NOT listen to my system time through accepting physical/local time as dominant and real time. I think it should, unless, the internet rules differs from reality.
I was just thinking that maybe EU/AMS time is some (new?) international standard that differs from, and is dominant above, local/real time. If this is the case, then I think it really sucks.
The consequence of this ‘newly introduced’ global standard could be/is that providers/data-centers and other people with access, can manipulate all data that is passing during this ‘time gap’.
If this is really the new reality, I think it could be (or maybe is!) a global main flaw in all global internet systems… Red Alert!

It seems to be a PEBKAC mis-configuration.

Nope, pretty sure it’s the abbreviation of the Europe/Amsterdam timezone. :grin:

https://wiki.archlinux.org/title/System_time#Time_standard

3 Likes

Those who do not understand UNIX are doomed to reinvent it ─ poorly. :grin:

UNIX normally always stores the hardware clock in UTC (GMT), and the system will then adjust the offset for each user account depending on their location, provided that the system was configured properly.

Microsoft Windows was not created as a multiuser operating system ─ let alone a networked one ─ but as a graphical user interface on top of DOS. That’s why Windows still defaults to storing the hardware clock in local time.

4 Likes

There is a real problem Linux solves/prevents with its way!

  • For comunicating round the world there is allover the same system-time (UTC). A timestamp created on any linux-system is valid and shows the right time on any other linux-system. And this without knowing the timezone of the sender :sunglasses: This is not only usefull for servers.
  • The second problem may hit you when your timezone has daylight saving time offsets. Twice in a year the time “jumps” by 60 Minutes back/forth. This does affect programs that work through that night, or that calcualte time-offsets. (UTC does not jump)
    root-tip-dual-boot-manjaro-and-windows : system-clock
2 Likes

UTC solves everything. I just didn’t know.
I know a lot, but do NOT know a lot more…

Thanks for your answer.

In my (old) BIOS I can only set the time, no timezones.

You are absolute right, I’ve grown up with DOS and Windows, and after many many years, I saw the Linux light shining bright. :innocent: Gladly there is/are many great alternatives, but Manjaro is definitely my favorite. So ye, I have to invest a lot of time to repair my lack of knowledge.
Gladly, a human is never too old to learn.

Thx for your shining ‘wisdom’.

The link mdt has in his post :point_up: shows the way to the ach-linux-wiki about system-time. This shows how to tell linux wehter the hardware-time ist UTC or not.

Did you set privacy.resistFingerprinting to true in the Firefox’s about:config of your user account?

Thx for the tip.

I already know of coarse the road to the wiki of arch. What I didn’t know is the meaning of the :point_up: emoticon (and many other I believe). Every day I learn a little bit more.
I really want to understand and learn the basic rules of Linux (Unix) bit by bit.
I love the concept op open source (and therefore Linux based OS); I never want to leave the basic path of the Unix concept, as far as I know and do understand.

Thx for your comment.
I did NOT set this parameter yet. I’m aware of this setting but don’t know anything about the impact of NOT setting to True. I will experiment with it and let it know when the time-gap still appears or not.

I think you’re right about the existing time-gap of 2 hours is (also) Firefox related.
In Manjaro I’ve already set my global system time to UTC. In my task toolbar I notice the right local time, as well in my normal user account, as well in my administrator (=not Root!!!) account.

I see this time-gap only when I use Ublock Logger. So It can also something to do with the extension uBlock Origin (and/or uMatrix). These Firefox extensions are by the way installed through the repository of Manjaro and not from within Firefox (as far if that’s possible). But I’ve already noticed that there is no difference in the effect: the 2 hours time-gap stays nevertheless.

I just get a tip to set explicitly in Firefox the ‘resist.fingerprinting’ to true. I let it know whether the effects changes with this parameter.

I’m quit sure it is definitely a Firefox related issue…

Although the system time-gap is technically solved with UTC settings, the time-gap in Firefox still stays and still differs (2-hours backwards) between normal user account and administrator (non-root but sudo). Firefox opened in the administrator account keeps informing (uBlock logger) me in the right local time, while opened with normal user account informs me 2 hours ‘earlier’.

So the main problem system wise may be solved or cleared, the official question isn’t answered yet.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.