Why is gnome opening activity after reboot?

Hi all,

I installed manjaro yesterday and everytime i reboot/log off and log in i see the activity screen opening. Is this normal ? why does it not select screen 1 by default ?

Is there a way i can change that ?



Yes, that is the new default on Gnome 40.
You can disable that with the extension gnome-shell-extension-just-perfection-desktop-git from AUR.

Hmmm oke, tried to look in the store and that one is not listed. I am new to linux, maybe a step to step ?

There’s also a setting in the extension Dash to Panel as well.To find the extension bogdancovaciu posted you need to enable AUR in pamac under preferences third party and check enable AUR support.

Thanks that did the trick, will report back if it worked or not :smiley:

@straycat, i managed to install the gnome-shell-extension-just-perfection-desktop-git from the store but when i reboot the pc it still did not fix the activity that boots up everytime

I haven’t used that extension I use dash to panel but I’m sure it has settings you can check and see how to set it up as you like it.Also you don’t have to reboot when you change a setting you can just log out and log back in.

You have to go to Extension - enable Just Perfection and tweak the part where startup will show Desktop instead of Over view.