Why does Pamac want to upgrade VirtualBox from the AUR?

In pamac I selected to install plasma-wayland-session. Before that I have requested pamac to ignore the aur upgrade from virtualbox-ext-oracle 7.0.6-3 to 7.0.8-1 since I am running virtualbox 7.0.6. (that upgrade was presented without my asking for it).
When installing plasma-wayland-session pamac wants to remove virtualbox 7.0.6-3 and virtualbox-host-dkms 7.0.6-3 and then build virtualbox-bin 7.0.8-1 and virtualbox-ext-oracle 7.0.8-1 both from aur.
Then it wants to install libidl2 0.8.14-6 req’d by virtualbox-bin and xorg-xwayland 23.1.1-1 and finally plasma-wayland-session

Why is pamac involving virtualbox in the install of plasma-wayland-session? What should / can I do to disentangle this? (I certainly do not want vs. 7.0.8 of virtualbox at this time).


Perhaps because when the manjaro Plasma ISOs are built, the developers still have this in mind.
#plasma-wayland-session # drop wayland support for now

T+ = See you later

Pamac is designed to automatically perform all updates before the installation of new software. This is intended to prevent issues that come with version mismatches, as Manjaro is a rolling distro.

As for AUR updates, they are not a very well-implemented feature. Pamac will look to the AUR to pull new updates for packages in the main repos, if the AUR is more up to date. This leads to it attempting to overwrite existing packages with new ones from the AUR, causing a bit of a mess. It is recommended to disable Pamac checking for AUR updates, and instead use a checker script.


bit of an incorrect way of saying “if AUR happens to have a package of same name as in manjaro repo, then it will get pulled”

This is a problem of manjaro vs aur, as aur is only curated against arch.

It tries to switch to the AUR version of Virtual Box because this is a dependency<->requirement of your extension pack AUR package. Your AUR package requires Virtualbox, at the proper version, and it is available in the AUR.

You did not configure something properly I guess if it doesn’t ignore your AUR update.

I had to explicitly add the virtualbox-ext-oracle package to the ignore list, not just unselect it in the to-be updated - list.

Yeah that’s how it works. You can unselect updates when you are only updating, but if you install new packages you have to be fully up to date. Again, the real solution is to go into Pamac preferences > third party > AUR > disable update checking

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.