Why does MHWD have me using old NVIDIA drivers?

I am running

  • kernel 6.1.19-1-Manjaro
  • Intel i7-1165G7
  • RTX 2060 12GB via thunderbolt 3 on Node Titan extenal enclosure
  • XFCE X Server 21.1.7

Disabling intel IBT fixed the Kernel boot issue (am not the same guy as the last post).

Nvidia released a driver fixing the issue:
Linux x64 (AMD64/EM64T) Display Driver | 530.41.03 | Linux 64-bit | NVIDIA

However upon running ‘mhwd -l’ I get really old options for drivers. The 2060 shouldn’t be so old not to support the latest drivers. Is this a Manjaro issue, or is this an nVidia issue?
Do you happen to know if there are plans for this version of the drivers to be available for my system in the upcoming months given the security issue?



530.41.03 is currently available in our unstable branch. See also Manjaro Features.


Looks like it is in Unstable branch.

1 Like

Thank you very much, looking at my version number it looks like I have the latest stable version. Running mhwd -l really confused me. I thought I was nowhere near close to the latest version. I appreciate the help. I’m still learning… Didn’t know how to search for what you just did.

Thank you as well, I appreciate the screenshot.

As far I’m concerned the topic can be marked solved.

You are the one that marks it as solved. You should have a proper box under every answer. Just choose the one that you feel is the best answer.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.