Why does BCMA module work on Manjaro but not on Arch?

I literally don’t know if I’m on the right place to ask this kind of question. But I ask.

I have a Broadcoam PCI wifi hardware(BCM4331). This hardware has two drivers.
The first is BCMA which is totally open source and it is part of Linux kernel.
The second one is WL, it is proprietary and it is not on the Kernel.

The WL has major problems. It disconnects randomly and so on. So, let’s talk about BCMA.

The BCMA works properly on Manjaro. On Manjaro, when I enter “lspci -v”, it says my hardware is loaded with BCMA driver. And the “module in use” is ‘bcma-pci-bridge’. On Manjaro, it connects properly to the WiFi and I can control it over NetworkManager.

On Arch linux, when I enter “lspci -v”, it says my hardware is loaded with the same BCMA driver. And the “module in use” is ‘bcma-pci-bridge’.But the problem is, I can not connect to the WiFi. It is not listed in ‘/sys/class/net’ (It is listed on Manjaro). The rfkill even can’t detect this device. And is not listed in ‘ip addr show’. The final words: it is loaded on lspci but I can not use it.

I want to know, what did the Manjaro developers change in Manjaro. Maybe some Kernel patches or additional packages they might installed. I want my Broadcom wifi work on Arch linux and other linux distributions.

Arch and Manjaro kernels are not the same.
Manjaro likely didn’t do something special to this particular driver.
I’d be surprised.
Perhaps try a different kernel in Arch (linux-zen or the LTS kernel).
And/or ask in the Arch forum why it doesn’t work there.

Did you check the Arch Wiki ?


Seems you need some additional firmware package.


There is a package manjaro-firmware which includes broadcom firmware files as well.
Most likely that’s the one that makes it work for you on manjaro…

I tried linux-zen, linux-lts and linux512-5.12.2(The manjaro kernel) right now.
Non of them worked

I tried manjaro-firmware right now. It works!!!

But I want to port it to Void Linux. Do you know where can I get the PKGBUILD file?

Usually they publish them on manjaro gitlab. Apparently not with that package though.
You should get those from the AUR package as well though.


Or just extract the firmware files from manjaro-firmware-20160419-1-any.pkg.tar.xz package and put them over to void…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.