Why can I only add specific resolution through nvidia settings?


So i’m trying to set a resolution that is not native to my screen. I have a 2560x1440 display but I want to set a 3440x1440 resolution as I’m remoting into that pc from an ultrawide.
I have tried to follow the wiki and fora online but I keep stumbling on the same error.
What I do is:
gtf 3440 1440 60 which gives me
3440x1440_60.00" 419.11 3440 3688 4064 4688 1440 1441 1444 1490 -HSync +Vsync
so then I do:
xrandr --newmode “3440x1440_60.00” 419.11 3440 3688 4064 4688 1440 1441 1444 1490 -HSync +Vsync
which works without any errors. Then i (have verified that it’s indeed hdmi-0):
xrandr --addmode HDMI-0 3440x1440_60.00
But that causes an error:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  39
  Current serial number in output stream:  40

What confuses me the most is that if I use the nvidia x server settings, i can set it to the right resolution no problem:

I’m guessing it has something to do with the View port out staying the same maybe?

Any ideas on what to do?