Why are Snap and Flatpak not in the Pamac GUI anymore?

I was just curious, why with the last updates snap and flatpak are not there in the pamac gui anymore?

Pamac is under serious developments currently
You have to install:

libpamac-snap-plugin and libpamac-flatpak-plugin for the moment, and voilà.

3 Likes

i have them.(under “third party” below the AUR.)

Edit:
Pamac 10.1.3-3
KDE full

Well you just have to enable them into Pamac preferences.

I do not have them either

So, nobody wants to post at least their pamac version but to only:
- It’s absent!
- No, it’s present!
- Absent!
- Present!

What’s next? :slight_smile:

Both are present for me:

$ pamac --version
Pamac  10.2.0beta2-1
$ kinfocenter about-distro

shows

Operating System: Manjaro Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.14.1-2-MANJARO (64-bit)
Graphics Platform: Wayland
2 Likes

Full versions have flatpak and snap support, minimal versions have not. At least with xfce it is the case and in gnome it might be the same.

2 Likes

I also found that issue in the manjaro kde minimal installation for LTS

those are not in the manjaro kde minimal installation for LTS

…no, it’s not an issue. It is a feature. Some users don’t like “third-party” support, they use minimal.
Full versions have it built in, you only have to enable it.

3 Likes

so how does one enables them,or change the Pamac version that came with the minimal edition?
i suppose that would solve OP’s question.

1 Like

Both wiki pages should be updated, in my opinion. Cuz, following these instructions won’t add options in default software manager to enable flatpaks and snaps. And it leads you to installing unnececcary software or to not existing package for snaps, or to broken solution.

All you need are these two plugins, that’s it. Options will appear in preferences menu in default package manager. In my case it was Gnome. You may need to reboot PC after applying flatpak and/or snap sliders.

3 Likes

Same here, and I tried the command libpamac-flatpak-plugin in terminal and it did not work.

10.2.0-1 version here. Cinnamon, Manjaro 21.12, System 76 Darter Pro (gen one).

Confirm. Possibly the solution of topic.

@Skaifer wrote about to install them. it is libraries, it contains modules, they are not designed to be directly executed, but as any library file designed to be used in any executable app or other library (hierarchy of library dependencies).
So just

sudo pacman -S libpamac-snap-plugin libpamac-flatpak-plugin

and re-read the Why are Snap and Flatpak not in the Pamac GUI anymore? - #13 by Skaifer

What i did recently (this week) is uninstall pamac-gtk and i reinstalled it, and then installed libpamac-flatpak-plugin.
Everything is ok now

1 Like

I had not thought about that, I might try that. I made the assumption (I know, I know), so I had not thought about uninstalling it. Thanks.

Wiki edit done and added the plugins.
Also edited the post title.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.