White border on XFCE?

That white border at the top, is anyone having it too? What is it?

I don't see any white border in the screenshot you're showing here. :thinking:

Is that only with Firefox? Maybe you could add a zoomed in screenshot with a window that is not fullscreen.

Edit: I think the Matcha window manager themes have this.

1 Like

The window manager theme (I think it's Matcha in this case) sets a top border for the windows, but it's definetely not white.

3 Likes

Do not use the forum preview tool. Open the image in a new tab, look at the top and you will see.

I've done that, but I still don't see any white border. What I do see ─ in closeup ─ is that there is a bit of a 3D effect going on at the top to make the window title bar stand out against any windows that are behind the active window, and if that's what you're worried about, then this is quite normal, and ─ as @datiswous said ─ part of the window decoration theme.

1 Like

I get a white border when I set Firefox to open with gtk3 (to enable removal of the top title bar, as a client side decoration) rather than the default using gtk3-classic. @Pakatonobr, is if possible that you have set Firefox to do the same?

1 Like

I can only go by what that screenshot shows. I only have Firefox as one of my alternative browsers, and I'm not using XFCE ─ I'm running KDE Plasma, and I use Chromium as my primary browser, and @torvic's Plasmafox as my secondary browser.

Was your message intended to be a reply to the OP instead of to my post, perhaps? :wink:

The window manager theme sets a top border using images. If you're using Matcha-sea, you can see the images in the directory /usr/share/themes/Matcha-sea/xfwm4/.
The names of the image files are:

title-1-active.png
title-2-active.png
...
title-5-active.png

If you zoom on these images, you'll see that at the top the color is a little lighter than the rest of the image.
You can change the top border color of the windows using Gimp, if that's what you want.

2 Likes

You were right, this was happening because of the Matcha themes. I installed the Numix theme and this border/effect is gone. Thank you all.

2 Likes

I added a name during my final edit, so it seems that our postings crossed over...

1 Like

Forum kindly sponsored by Bytemark