Whisker menu not closing correctly


I have an issue where my whisker menu binding doesn’t work correctly.

If I press the super or alt+f1 key(s) to close the menu. It instantly pops back up. If I quickly press the button twice it will close. It sometimes will stop and work correctly, but when I go to use the computer next it returns.

Any suggestions? Thanks.


  Kernel: 5.10.68-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=2a86e105-1e12-4ddb-9fb7-5d803efea2af rw quiet udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: TOSHIBA product: Satellite L655 v: PSK2CU-0QU01U 
  serial: <filter> 
  Mobo: Intel model: N/A serial: <filter> BIOS: INSYDE v: 2.80 
  date: 07/03/2012 
  ID-1: BAT1 charge: 4.1 Wh (95.3%) condition: 4.3/4.2 Wh (101.9%) volts: 11.7 
  min: 11.7 model: LGC PA3817U-1BRS type: Li-ion serial: N/A 
  status: Discharging cycles: 1 
  RAM: total: 3.64 GiB used: 959.2 MiB (25.7%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i5 M 560 bits: 64 type: MT MCP 
  arch: Nehalem family: 6 model-id: 25 (37) stepping: 5 microcode: 7 cache: 
  L2: 3 MiB bogomips: 21285 
  Speed: 1197 MHz min/max: 1199/2667 MHz boost: enabled Core speeds (MHz): 
  1: 1197 2: 1197 3: 1197 4: 1197 
  Flags: acpi aes aperfmperf apic arat arch_perfmon bts clflush cmov 
  constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts ept est flexpriority 
  flush_l1d fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce mmx monitor msr mtrr 
  nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs pge pni popcnt pse 
  pse36 pti rdtscp rep_good sep smx ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp 
  syscall tm tm2 tpr_shadow tsc vme vmx vnmi vpid xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds 
  status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Core Processor Integrated Graphics vendor: Toshiba 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0046 class-ID: 0300 
  Device-2: Chicony CNF9055 Toshiba Webcam type: USB driver: uvcvideo 
  bus-ID: 2-1.1:3 chip-ID: 04f2:b1d6 class-ID: 0e02 
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (ILK) v: 2.1 Mesa 21.2.2 
  direct render: Yes 
  Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Toshiba 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.68-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.37 running: no 
  Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel port: 5000 
  bus-ID: 02:00.0 chip-ID: 8086:08b1 class-ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  Device-2: Qualcomm Atheros AR8152 v1.1 Fast Ethernet vendor: Toshiba 
  driver: atl1c v: kernel port: 2000 bus-ID: 03:00.0 chip-ID: 1969:2060 
  class-ID: 0200 
  IF: enp3s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 2-1.6:5 chip-ID: 8087:07dc class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 585 GiB used: 240.35 GiB (41.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: OCZ model: VERTEX4 size: 119.24 GiB 
  block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD 
  serial: <filter> rev: 1.5 scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HTS725050A9A364 
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  type: HDD rpm: 7200 serial: <filter> rev: C72E scheme: MBR 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 119.24 GiB size: 116.81 GiB (97.96%) 
  used: 39.69 GiB (34.0%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 2a86e105-1e12-4ddb-9fb7-5d803efea2af 
  ID-2: /mnt/Storage raw-size: 414.98 GiB size: 407.4 GiB (98.17%) 
  used: 200.67 GiB (49.3%) fs: ext4 dev: /dev/sdb4 maj-min: 8:20 
  label: Storage uuid: 3062e558-ecfc-419a-87d1-3289f9d1e4ce 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
  ID-1: /dev/sdb1 maj-min: 8:17 size: 50 MiB fs: ntfs label: System Reserved 
  uuid: 3A6E65AE6E65639B 
  ID-2: /dev/sdb2 maj-min: 8:18 size: 50.25 GiB fs: ntfs label: N/A 
  uuid: 121E913F1E911CB3 
  ID-3: /dev/sdb3 maj-min: 8:19 size: 498 MiB fs: ntfs label: N/A 
  uuid: E04CE5DD4CE5AE8A 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 3 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:0020 class-ID: 0900 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 3 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:0020 class-ID: 0900 
  Device-1: 2-1.1:3 info: Chicony CNF9055 Toshiba Webcam type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 04f2:b1d6 class-ID: 0e02 
  Device-2: 2-1.4:4 info: Realtek USB 2.0 multicard reader type: Mass Storage 
  driver: ums-realtek interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 0bda:0158 class-ID: 0806 serial: <filter> 
  Device-3: 2-1.6:5 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:07dc class-ID: e001 
  System Temperatures: cpu: 38.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 204 Uptime: 0m wakeups: 1 Init: systemd v: 249 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: pacman: 1041 lib: 288 Shell: Bash v: 5.1.8 
  running-in: xfce4-terminal inxi: 3.3.06 

The command
is bound to Alt+F1 only by default.
I know that the Super key seems to do the same - but it is not set as a keyboard shortcut to do this.
Why it does seem to work … I don’t know.
But as you found out, it does not work reliably - probably because it is not a key combination, but a single key
and it is uncertain whether it works on depress or on release.

To have the Super key open and close the whisker menu
you would have to use some helper program such as sxhkd or ksuperkey
which will generate (for instance) Alt+F1 when the Super key is pressed.

KDE uses this (sxhkd) - AFAIK.
In my installation, which is not Manjaro, but Arch installed via the Archlabs installer, ksuperkey is used.

Without this, the Super key all by itself will not reliably do what you want - you can’t even set it as a hotkey/keyboard shortcut if you try …

Thanks for the response.

In researching the subject I have come across the ksuperkey package. However Manjaro has something installed by default. Using the combo alt+f1. I’m unsure what package this is and where it’s configuration is. I moved over some files from my old Manjaro install when I formatted. Possibly this is a permissions issue.

The menu opens fine. However when I press the button again to close the menu. It instantly pops up. If I quickly press it twice. It will successfully close.

Earlier I removed a duplicate .desktop file that was in both the local and system applications directories. The menu would open up normally when I deleted those files. Restarting it seemed fine. I thought I fixed it. I powered it off and went to use it again and it returned. It’s a very strange anomaly.

I may try to chown -R my entire user folder since that is where I copied files to. Maybe something in there is set to root only.

the menu popup in Xfce is configured via
the xfce4-settings-manager (or when you click the menu)
then: Keyboard → Application shortcuts
There, only Alt+F1 is set as the shortcut to pop up the whisker menu
and this combination (probably) works reliably.

Does it?

What doesn’t work reliably - and I don’t know why it works at all - is the Super key to do the same.
But this is nowhere configured and not even configurable (the Super key by itself)
via the Application shortcuts tab.
Helper programs are needed - such as ksuperkey.

alt+f1 has the same issues. If I press that combo to close the menu it will pop up again. If I press it quickly it will close.

in that case:
I don’t know what your issue could be

For me, it opens on the first press of Alt+F1 - and closes on the next Alt+F1 - and so on … reliably.
Even if I stay on Alt and just press F1 repeatedly - is opens, closes, opens, closes, …

What I do know is that the Super key (by itself) is not even supposed to work - even though it kinda does …

It seems Manjaro uses xcape as it’s helper. Trying to figure out where to go from here. Hopefully someone else has an answer.

Strange. So it works correctly when the laptop is in the charging state. However when its running on battery is when the whisker menu fails to close when I press the button.

I do use a package called auto-cpufreq, however I don’t think this is the issue. I noticed it’s installed from the AUR and it’s the -git package. I see it’s been added to the official repo. Shutdown the laptop and I’m going to install the official package. Again I don’t believe this is the issue.

Ah, ok - I didn’t know and learned something new to me.
It is active in my xfce system running in a VM.

The left Super key should produce Alt+F1 with this.
Apparently it doesn’t.
because, as I said:
Alt+F1 works for me
Super key … doesn’t - not reliably.

So the problem is the auto-cpufreq package. Suppose I’ll post on their github as an issue. I uninstalled the package and while it was uninstalled the menu closed properly on battery power. Installed the newer package and enabled its systemd service. Now it won’t close properly.

This is actually really starting to tick me off. I tried stopping the service to verify. The menu is doing it again. Popping up again when it should close. Even when it’s charging. So no idea what the issue is yet again… This is really irritating.

Restarted the laptop with the service disabled and stopped. Now the menu works properly. Has to be something to do with this auto-cpufreq package. Specifically when in the power save governor.

I reported this issue on whisker menu and they managed to fixed it

Thank you very much. I found the post. Hopefully this gets pushed to the Manjaro repo sometime. I stopped using the auto-cpufreq package for now until it is fixed. Been driving me nuts lol.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.