Whipper doesn't seem to work anymore?

I haven’t ripped any CDs for a few months. Bought some a couple days ago, but I was greeted by this when I tried to rip them with whipper:

~ >>> whipper cd rip                                                                                                                                                                                                           
INFO:whipper.command.cd:using configured read offset 6
INFO:whipper.command.cd:checking device /dev/sr0
WARNING:whipper.program.utils:command 'eject -t /dev/sr0' returned with exit code '1' (b'eject: CD-ROM tray close command failed: Input/output error')
CDDB disc id: 7b0bcb09
Traceback (most recent call last):
  File "/usr/bin/whipper", line 33, in <module>
    sys.exit(load_entry_point('whipper==0.10.0', 'console_scripts', 'whipper')())
  File "/usr/lib/python3.9/site-packages/whipper/command/main.py", line 56, in main
    ret = cmd.do()
  File "/usr/lib/python3.9/site-packages/whipper/command/basecommand.py", line 141, in do
    return self.cmd.do()
  File "/usr/lib/python3.9/site-packages/whipper/command/basecommand.py", line 141, in do
    return self.cmd.do()
  File "/usr/lib/python3.9/site-packages/whipper/command/cd.py", line 116, in do
    self.mbdiscid = self.ittoc.getMusicBrainzDiscId()
  File "/usr/lib/python3.9/site-packages/whipper/image/table.py", line 368, in getMusicBrainzDiscId
    from discid import put
ModuleNotFoundError: No module named 'discid'

I have tried reinstalling whipper, twice.

System information
System:    Kernel: 5.13.1-3-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 root=UUID=c28c9ba1-1ab9-48ed-a6c3-a5cf6794acea ro apparmor=1 
           security=apparmor udev.log_priority=3 sysrq_always_enabled=1 
           Desktop: KDE Plasma 5.22.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: B450M MORTAR MAX (MS-7B89) v: 1.0 serial: <filter> 
           UEFI: American Megatrends LLC. v: 2.D0 date: 05/17/2021 
CPU:       Info: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 stepping: 2 
           microcode: 800820D cache: L2: 4 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 118457 
           Speed: 2237 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 1: 2237 2: 2905 3: 2165 4: 2180 5: 2197 
           6: 2019 7: 3738 8: 2097 9: 2161 10: 2123 11: 2844 12: 2274 13: 2195 14: 2102 15: 3155 16: 2898 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: ASUSTeK driver: nvidia v: 470.42.01 
           alternate: nouveau,nvidia_drm bus-ID: 26:00.0 chip-ID: 10de:1b06 class-ID: 0300 
           Display: x11 server: X.Org 1.20.12 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x342mm (23.7x13.5") s-diag: 692mm (27.3") 
           Monitor-1: DP-0 res: 2560x1440 hz: 144 dpi: 109 size: 597x336mm (23.5x13.2") diag: 685mm (27") 
           OpenGL: renderer: NVIDIA GeForce GTX 1080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 470.42.01 direct render: Yes 
Audio:     Device-1: NVIDIA GP102 HDMI Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 26:00.1 
           chip-ID: 10de:10ef class-ID: 0403 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus-ID: 28:00.3 chip-ID: 1022:1457 class-ID: 0403 
           Device-3: GYROCOM C&C UAC1 DAC type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-10:2 chip-ID: 1852:5110 
           class-ID: 0102 
           Sound Server-1: ALSA v: k5.13.1-3-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.31 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: e000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
RAID:      Supported mdraid levels: raid0 
           Device-1: md0 maj-min: 9:0 type: mdraid level: raid-0 status: active size: 744.74 GiB 
           Info: report: N/A blocks: 780914688 chunk-size: 512k super-blocks: 1.2 
           Components: Online: 
           0: sdb maj-min: 8:16 size: 186.31 GiB 
           1: sde maj-min: 8:64 size: 186.31 GiB 
           2: sdc maj-min: 8:32 size: 186.31 GiB 
           3: sdd maj-min: 8:48 size: 186.31 GiB 
Drives:    Local Storage: total: raw: 1.18 TiB usable: 1.18 TiB used: 552.73 GiB (45.7%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 4B6Q scheme: GPT 
           ID-2: /dev/sdb maj-min: 8:16 model: SSD 910 200GB size: 186.31 GiB block-size: physical: 4096 B logical: 512 B 
           rotation: SSD serial: N/A rev: a424 
           ID-3: /dev/sdc maj-min: 8:32 model: SSD 910 200GB size: 186.31 GiB block-size: physical: 4096 B logical: 512 B 
           rotation: SSD serial: N/A rev: a424 
           ID-4: /dev/sdd maj-min: 8:48 model: SSD 910 200GB size: 186.31 GiB block-size: physical: 4096 B logical: 512 B 
           rotation: SSD serial: N/A rev: a424 
           ID-5: /dev/sde maj-min: 8:64 model: SSD 910 200GB size: 186.31 GiB block-size: physical: 4096 B logical: 512 B 
           rotation: SSD serial: N/A rev: a424 
Partition: ID-1: / raw-size: 465.26 GiB size: 456.96 GiB (98.22%) used: 193.11 GiB (42.3%) fs: ext4 dev: /dev/sda2 
           maj-min: 8:2 
           ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
           ID-1: swap-1 type: file size: 2 GiB used: 8.5 MiB (0.4%) priority: -2 file: /mnt/faaast/swap 
Sensors:   System Temperatures: cpu: 54.6 C mobo: 47.0 C gpu: nvidia temp: 53 C 
           Fan Speeds (RPM): fan-1: 0 fan-2: 1356 fan-3: 1018 fan-4: 657 fan-5: 880 gpu: nvidia fan: 51% 
Info:      Processes: 343 Uptime: 3h 34m wakeups: 0 Memory: 31.28 GiB used: 4.48 GiB (14.3%) Init: systemd v: 249 
           tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1355 lib: 406 Shell: Zsh v: 5.8 running-in: yakuake 
           inxi: 3.3.04

It seems the whipper package is missing a dependency, python-discid, but it is in the Manjaro repos. Whipper starts operating normally after installing the package.
Could you add this dependency, pretty please? :pray: @Yochanan

whipper is taken from arch - does it have the same problem there?

Packager        : Christian Rebischke <Chris.Rebischke@archlinux.org>

If so, fixing its dependencies in arch seems to be the better solution.

I’ll email them about it. Thanks!

Edit: There appears to be a bug report about this: FS#71217 : [whipper] Missing python-discid dependency
But I’ll send mail all the same, since nothing’s been done about it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.