Where is memtest?

I’d like to use memtest86+. I can’t find it in the GRUB menu generated by Manjaro.
Why? How do I start it?

I found this:
https://wiki.archlinux.org/index.php/Stress_Test#Running_Memtest86.2B

which suggests doing this:
https://wiki.archlinux.org/index.php/GRUB#Generate_the_main_configuration_file

I don’t think it’s a solution, since Memtest was already installed and I updated the Kernel more than once since I installed Manjaro. But locate grub.cfg gives:

/boot/efi/EFI/ubuntu/grub.cfg
/boot/efi/boot-sav/log/2016-01-31__01h49boot-repair58/sda6/grub.cfg_old
/boot/efi/boot-sav/log/2016-01-31__01h49boot-repair58/sda7/grub.cfg_old
/boot/efi/boot-sav/log/2016-05-03__14h01boot-repair23/sda7/grub.cfg_old
/boot/grub/grub.cfg

Should I update just the last one, the first one or both?

boot to your live iso, 5th option down, Memory Test

If you have EFI you have to use the proprietary memtest-efi (or something similar) from AUR.

Oh, so EFi machines do not get the memtest option in GRUB?
That would explain why it’s missing on some of my machines, but not on others.

1 Like

As far as I know the memtest package included in repositories is not able to create an EFI executable file.
I assume that memtest can’t “test” after EFI loaded grub, but it’s an assumption obviously, I don’t know how that works.

Didn’t notice this but yes there is no Memtest option on efi

Could you please explain how to do that step by step?

I tried $ yaourt memtest86-efi but it’s asking me to modify PKGBUILD and I don’t know what to do.

Please read the wiki page before using yaourt to install packages from AUR.

I did and went through the installation process. At the end it says:

You can use command memtest86-efi --install as root to install MemTest86 in your ESP.
Dipendenze opzionali di memtest86-efi
    efibootmgr: to add a new EFI boot entry [installato]
    grub: to add MemTest86 entry in GRUB2 menu [installato]

I don’t know what an ESP is, should I run memtest86-efi --install?

I don’t remember what I’ve done (months ago) but I think that it’s correct.

O.T. Vedo che sei italiano, ti segnalo che esiste un forum italiano di Manjaro, nel caso in cui ti interessi.

I ran $ memtest86-efi --install.

There are five options (see below): I chose #2, rebooted, and the GRUB menu was gone. Instead of it, the PC booted directly into memtest.

I rebooted again and selected Manjaro from the boot menu (my motherboard’s one, not GRUB’s one). Then GRUB was there, but no boot option for Memtest. I started Manjaro again, then ran $ sudo memtest86-efi --remove. Then I tried again with option #3:

$ sudo memtest86-efi --install
This script is unofficial, written by an AUR (Arch User Repository) user. Use it at YOUR OWN RISK.
Partition 1 does not start on physical sector boundary.
Press Enter if /dev/sda1 is your ESP partition, else enter device path manually (like /dev/sdXY): 
Press Enter if /boot/efi is your mount point, else enter mount point manually (like /boot/efi): 
The target is: /dev/sda1 (mounted on /boot/efi).

Select memtest86-efi action to perform:
1: Copy shellx64.efi file on ESP's root (bit safe)
2: Add a new EFI boot entry (more safe)
3: Add a boot entry for GRUB2 menu
4: Add a boot entry for systemd-boot menu
5: Cancel
3

MemTest86 will be installed in /boot/efi/EFI/memtest86/.
mkdir: created directory '/boot/efi/EFI/memtest86'
'/usr/share/memtest86-efi/bootx64.efi' -> '/boot/efi/EFI/memtest86/bootx64.efi'
'/usr/share/memtest86-efi/mt86.png' -> '/boot/efi/EFI/memtest86/mt86.png'
'/usr/share/memtest86-efi/unifont.bin' -> '/boot/efi/EFI/memtest86/unifont.bin'
'/boot/efi/EFI/memtest86/bootx64.efi' -> '/boot/efi/EFI/memtest86/memtestx64.efi'

Add a new configuration file for GRUB...
'/etc/memtest86-efi/grub.conf' -> '/etc/grub.d/86_memtest'
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found Intel Microcode image
Found linux image: /boot/vmlinuz-4.6-x86_64
Found initrd image: /boot/initramfs-4.6-x86_64.img
Found initrd fallback image: /boot/initramfs-4.6-x86_64-fallback.img
Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
Found Linux Mint 17.2 Rafaela (17.2) on /dev/sda4
Found Ubuntu 14.04.3 LTS (14.04) on /dev/sda6
Found Ubuntu 16.04 LTS (16.04) on /dev/sda7
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
Writting configuration...

MemTest86 has been installed in ESP.

But still no GRUB entry for memtest when I reboot.

Do I have to run a grub-install or something? If yes, with which options? I’ve never done this manually in Manjaro nor in a UEFI system and I don’t want to break things more.

OT: Why is there an Intel Microcode entry? I’ve got AMD CPU and chipset, there should be nothing by Intel in my PC.

ESP = EFI System Partition.
Most likely something like a 512mb fat32 /boot/efi/ partition at the front of your drive.

The notes are saying that now in your EFI boot menu, you will have options like ‘boot hard disk’, and ‘memtest’ or however your setup works out after you install.

Note - this is different from grub boot menu. And different from bios. This is the EFI boot menu that will show after your hit f12 at boot or whatever key combination is for your machine.

https://wiki.archlinux.org/index.php/EFI_System_Partition

https://wiki.archlinux.org/index.php/Unified_Extensible_Firmware_Interface

And maybe an example of EFI boot menu:

It’s exactly what you need, a new entry in EFI boot menu; I’ve said that you can’t start memtest after loading GRUB, so the install script make a new boot entry (in your EFI boot menu, not in GRUB) and you can boot with memtest instead of GRUB.
With EFI you have to do like that, if you want a simpler EFI boot menu you can take a look at rEFInd.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by