When trying to open an app from a workspace, opens in another workspace instead


I have this problem with applications in general, when opening an app from any workspace, the application opens in another workspace instead. I prefer that the applications open in the workspace where they were invoked, is there an option to do this?

Is a fresh installation of Manjaro KDE Plasma.

Thanks in advance.


I was able to fix it.

Kwinrules forced certain windows to open in specific work environments.
To solve it, go to:

  • System Settings
  • window management
  • window rules
  • edit the rules of the programs that are forced to appear in a specific work environment.

Glad you were able to solve it

don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

BTW, that settings section by default is clean: there is no rules at least on my OS copy.
It looks like you cleaned up your prev. footsteps :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.