When is dolphin going to be updated to use polkit?

dolphin

#1

im aware of why i cant use dolphin to view inside root folders but it must have been a year now that i have had to use other file browsers or terminal to do this. I read ages ago that dolphin would have polkit but when ?


#2

What do you mean. I can view root owned folder fine with Dolphin.

Folders where ONLY root can read should not be viewable in Dolphin anyhow, there’s a reason it’s like that.

It all depends on the permissions on the folders in question.
Example. The /etc folder should be viewable with Dolphin, but the contents of /root/ should not.


#3

well yea thats what i mean , I have used timeshift for ages and it mounts the partition im using for backup as root RW only but that means the option in timeshift to “view backups in dolphin” does not work and i cant view them manually either (well not with dolphin).

O dam , looks like iv got even worse problem, I just tried to run timeshift and for some reason the dam timeshit GUI just closes after entering my password. removed and re-installed but still fails. I better try and figure whats happened to timeshift now :frowning:


#4

just do this for your timeshift issue


#5

sorry , what ? whats wrong with my path and what do i do ?

❰greg❙~❱✘≻ echo $PATH
/home/greg/bash /home/greg/python /home/greg/.autojump/bin /bin /usr/bin /usr/local/bin /usr/local/sbin /usr/lib/jvm/default/bin /usr/bin/site_perl /usr/bin/vendor_perl /usr/bin/core_perl
❰greg❙~❱:heavy_check_mark:

EDIT:- do i just remove the PATH line in /etc/sddm.conf ?


#6

the wiki from stable update, or the way was solved by @scachemaille i the link i provided first.
if in the command echo $PATH you identify /bin then that breaks the usability of polkit, so that is why you have to EDIT /etc/sddm.conf as clearly explained in both places :slight_smile:


#7

ahh, thx. Yea im terrible at reading and searching and reading some more etc. I skimmed the link you gave above but just scratched my head :blush:

Ok i shall give that a go, i know it correct cos i see it a polkit error from my journalctl logs.

Anyhow … so yea i still cant view my backups from timeshift.


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.