When I try to install Manjaro Gnome/KDE screen blinks when moving the mouse

Notebook Asus Vivobook Pro 16X

  • CPU: Intel Core i7-11370H (3.3 — 4.8 ГГц)
  • Intel Iris Xe Graphics
  • NVIDIA GeForce RTX 3050

I can’t go through the installation steps due to very frequent screen flickers.
Try another distro but the same. Attach video with the last try on Ubuntu for demo.

Is this problem likely to remain after installation and how to deal with it?
Can anyone help me with this?


You could try to add a boot parameter in grub and try if this problem still exist.


Is it possible (and if yes - how) to add this option to grub when I try to install Manjaro from a flash drive? It’s a clean notebook without any grub yet.
Or it can be done once the system is installed?

Thanks for the helping :slight_smile:

You can add the parameter before you boot and test it. If it works you have to add this parameter again after you installed Manjaro.

I cannot link the wiki. Search for “grub kernel parameter”

Press e when the grub menu shows up and add them on the linux line:

linux /boot/vmlinuz-linux root=UUID=0a3407de-014b-458b-b5c1-848e92a327a3 rw quiet splash i915.enable_psr=0

Press Ctrl+x to boot with these parameters

1 Like

In grub menu presents Boot with open/proprietary drivers.
Press e on open-source drivers and see a similar line already.
Need to modify this one or add it below?

I added this option i915.enable_psr=0 inside this string after i915.modeset=1 and everything works.
Thanks :slight_smile:

You’re welcome :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.